summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-13 02:43:40 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-13 02:48:08 -0600
commitba9195efefe38f5007c2bea862d6658e455090f1 (patch)
tree83465f3693d111820521fd1c08ef26633bc0e7aa /app-backup/bup
parentsys-devel/binutils-apple: force gcc-apple usage if necessary (diff)
downloadgentoo-ba9195efefe38f5007c2bea862d6658e455090f1.tar.gz
gentoo-ba9195efefe38f5007c2bea862d6658e455090f1.tar.bz2
gentoo-ba9195efefe38f5007c2bea862d6658e455090f1.zip
app-backup/bup: version bump to 0.29.2
Closes: https://bugs.gentoo.org/661390 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-backup/bup')
-rw-r--r--app-backup/bup/Manifest1
-rw-r--r--app-backup/bup/bup-0.29.2.ebuild56
-rw-r--r--app-backup/bup/files/bup-0.29.2-sitedir.patch38
3 files changed, 95 insertions, 0 deletions
diff --git a/app-backup/bup/Manifest b/app-backup/bup/Manifest
index 0879d384f801..ccaedbfe2e9f 100644
--- a/app-backup/bup/Manifest
+++ b/app-backup/bup/Manifest
@@ -1,3 +1,4 @@
DIST bup-0.28.1.tar.gz 377712 BLAKE2B b469af7b40807e1462c603c03078fc4e048fc300f74dccba9db4ee9d5b1cd385b3092c2bcc08b60ba798e4f401953ccb3217275c6afb3ebf8040e6e507fde9fd SHA512 b27a94eeee86366f9f97081611d8e0443686ed8c4070d45729ad4efe1d48ee9f528d3257bfd5d37d6243927f5b63d6b613bf5ae2c39117012979ccd5ccecf9d2
DIST bup-0.29.1.tar.gz 388654 BLAKE2B e0a1bd6606f0b2fa7fc50f7df46d2f1704b2bec7e9ac7ff8b97f0bc46081fd4c506f2f12af73e952854746bdf0de5b713d0d5519d99bebafb8c4b62f782ebd09 SHA512 2ad142214cf5ee61e2113b49d02761cdf8fdd5928eb4f885230af71f149ba33ee748e1d96e240903f54d3264dc2ad1614e6ece66027b4c7ed1e97b6147a9685e
+DIST bup-0.29.2.tar.gz 389145 BLAKE2B 1a54cb68b2c68ecf4902a7f1ee940711b62e413c69d17ba1515f24e115484bac1b4919947f2214ffff784389839f633fbb13dea69c186246426e57c33a148c4c SHA512 10c433d6779b1fd7e1935c587676492d96a330dc3280556332bb55b6e5c62de8631fd755d07d2eaf80cb9fa209dc25b241d5ecf3a6fe2b8210a3d0e1ce4fa4bf
DIST bup-0.29.tar.gz 388173 BLAKE2B 4d844aa616daa56e457a6164a8a00521c3cc2fe56a4f7b3e73b3cdfa4d42977652b203756198e3b8222de5e49b6d0cadd340f70f79e0a1878f4af80dd2b4d2d7 SHA512 3a70d747c6bae2640809d48141b726fa7897f33af9f19047c8d4cfba88abe04ac907980f0ce572847b900e2c8d02a3303e886c8ad7af9a97a7804540c7da1705
diff --git a/app-backup/bup/bup-0.29.2.ebuild b/app-backup/bup/bup-0.29.2.ebuild
new file mode 100644
index 000000000000..e42e7328e08f
--- /dev/null
+++ b/app-backup/bup/bup-0.29.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="A highly efficient backup system based on the git packfile format"
+HOMEPAGE="https://bup.github.io/ https://github.com/bup/bup"
+SRC_URI="https://github.com/bup/bup/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+doc test web"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-arch/par2cmdline
+ dev-python/fuse-python[${PYTHON_USEDEP}]
+ dev-python/pylibacl[${PYTHON_USEDEP}]
+ dev-python/pyxattr[${PYTHON_USEDEP}]
+ web? ( www-servers/tornado[${PYTHON_USEDEP}] )
+ sys-libs/readline:0
+ dev-vcs/git"
+DEPEND="${RDEPEND}
+ test? (
+ dev-lang/perl
+ net-misc/rsync
+ )
+ doc? ( app-text/pandoc )
+"
+
+# unresolved sandbox issues
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${P}-sitedir.patch )
+
+src_configure() {
+ # only build/install docs if enabled
+ export PANDOC=$(usex doc pandoc "")
+
+ ./configure || die
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr DOCDIR="/usr/share/${PF}" \
+ SITEDIR="$(python_get_sitedir)" install
+ python_fix_shebang "${ED}"
+ python_optimize "${ED}"
+}
diff --git a/app-backup/bup/files/bup-0.29.2-sitedir.patch b/app-backup/bup/files/bup-0.29.2-sitedir.patch
new file mode 100644
index 000000000000..920b3dc27921
--- /dev/null
+++ b/app-backup/bup/files/bup-0.29.2-sitedir.patch
@@ -0,0 +1,38 @@
+--- bup-0.29.2/Makefile
++++ bup-0.29.2/Makefile
+@@ -25,7 +25,7 @@
+ os := $(shell ($(pf); uname | sed 's/[-_].*//') $(isok))
+ os := $(call shout,$(os),Unable to determine OS)
+
+-CFLAGS := -Wall -O2 -Werror -Wno-unknown-pragmas $(PYINCLUDE) $(CFLAGS)
++CFLAGS := -Wall -Wno-unknown-pragmas $(PYINCLUDE) $(CFLAGS)
+ CFLAGS := -D_FILE_OFFSET_BITS=64 $(CFLAGS)
+ SOEXT:=.so
+
+@@ -93,10 +93,11 @@
+ dest_docdir := $(DESTDIR)$(DOCDIR)
+ dest_bindir := $(DESTDIR)$(BINDIR)
+ dest_libdir := $(DESTDIR)$(LIBDIR)
++dest_sitedir := $(DESTDIR)$(SITEDIR)
+
+ install: all
+- $(INSTALL) -d $(dest_bindir) \
+- $(dest_libdir)/bup $(dest_libdir)/cmd \
++ $(INSTALL) -d $(dest_bindir) $(dest_libdir) \
++ $(dest_sitedir)/bup $(dest_libdir)/cmd \
+ $(dest_libdir)/web $(dest_libdir)/web/static
+ test -z "$(man_roff)" || install -d $(dest_mandir)/man1
+ test -z "$(man_roff)" || $(INSTALL) -m 0644 $(man_roff) $(dest_mandir)/man1
+@@ -109,10 +110,10 @@
+ done
+ $(INSTALL) -pm 0644 \
+ lib/bup/*.py \
+- $(dest_libdir)/bup
++ $(dest_sitedir)/bup
+ $(INSTALL) -pm 0755 \
+ lib/bup/*$(SOEXT) \
+- $(dest_libdir)/bup
++ $(dest_sitedir)/bup
+ $(INSTALL) -pm 0644 \
+ lib/web/static/* \
+ $(dest_libdir)/web/static/