summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-10-02 22:56:49 +0200
committerMatt Turner <mattst88@gentoo.org>2022-10-09 22:34:12 -0400
commitdd1bfbc402a89003990aca7511b6d50e57133c5d (patch)
treec3f807ebdaa696298a854802f96349eefdc1415d /app-backup/deja-dup
parentmedia-video/pitivi: Drop old versions (diff)
downloadgentoo-dd1bfbc402a89003990aca7511b6d50e57133c5d.tar.gz
gentoo-dd1bfbc402a89003990aca7511b6d50e57133c5d.tar.bz2
gentoo-dd1bfbc402a89003990aca7511b6d50e57133c5d.zip
app-backup/deja-dup: Version bump to 43.4
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-backup/deja-dup')
-rw-r--r--app-backup/deja-dup/Manifest1
-rw-r--r--app-backup/deja-dup/deja-dup-43.4.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-backup/deja-dup/Manifest b/app-backup/deja-dup/Manifest
index ef328d5a8735..e7e3e533f344 100644
--- a/app-backup/deja-dup/Manifest
+++ b/app-backup/deja-dup/Manifest
@@ -1,2 +1,3 @@
DIST deja-dup-42.7.tar.bz2 1384797 BLAKE2B f462df835039606b721d935e086e51ee27e861baa1fbc5836bb79952c838921cf5f28d439465451c5259bc2c77fa9cb839488c8b0196c6d176e32d9e42180539 SHA512 80c57fe75635346cf2597195e7f7b76e2562aaa6900e78fbfb7ad6ada9c268df36d4e16aa7ca522e1570987f5826586e1cab5fecb7d5ba90e34a23a349b47a74
DIST deja-dup-42.8.tar.bz2 1467818 BLAKE2B 6f02fc458890f076bf0a8e1ffdc9d72880fd9f1a692d439ecfa5d8b08234472f3ae27aa801144b3e42e9c8b67b550c0882dc93c23d27e6e428ce1eddd80a912d SHA512 76c98e8635ffae076008efa73a92860c6d4e67d39339d452c253269bb3ed032b819ac40d65c2d8fbf195ecaf304796f516e861b0552be972838f95bf59af0a5c
+DIST deja-dup-43.4.tar.bz2 989830 BLAKE2B c67056b4498dbdb8f1346d682449e4a23070f052d6c4b3e205bd10da63148a6327666de79d163bd6450b34c130fedcdccc2053fabf7578a2d7d68decb325f510 SHA512 2413a3b1ef891e0151d61ee6fcec00f609f209da0faebe387dc8dba4abb55aa4ed925bdfee5768c7e8e8794bc9a793fb0769947030102aed57ac56983cd78943
diff --git a/app-backup/deja-dup/deja-dup-43.4.ebuild b/app-backup/deja-dup/deja-dup-43.4.ebuild
new file mode 100644
index 000000000000..b05a0347fbcb
--- /dev/null
+++ b/app-backup/deja-dup/deja-dup-43.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson gnome2-utils vala xdg
+
+DESCRIPTION="Simple backup tool using duplicity back-end"
+HOMEPAGE="https://wiki.gnome.org/Apps/DejaDup"
+SRC_URI="https://gitlab.gnome.org/World/deja-dup/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ $(vala_depend)
+ dev-util/intltool
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( dev-libs/appstream-glib )
+"
+
+# deja-dup can not recognize duplicity-1.0.0 and throws an error
+# https://gitlab.gnome.org/World/deja-dup/-/issues/334
+DEPEND="
+ >=gui-libs/libadwaita-1.0:1
+ >=dev-libs/glib-2.70.0:2
+ >=dev-libs/libgpg-error-1.33
+ >=gui-libs/gtk-4.6:4
+ >=dev-libs/json-glib-1.2
+ >=dev-libs/glib-2.64:2[dbus]
+ >=app-crypt/libsecret-0.18.6[vala]
+ >=net-libs/libsoup-3.0:3.0
+ >=app-backup/duplicity-0.8.21
+ <app-backup/duplicity-1.0.0
+"
+
+RDEPEND="${DEPEND}
+ gnome-base/dconf
+ gnome-base/gvfs[fuse]
+"
+
+src_prepare() {
+ default
+ vala_setup
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}