summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-02-06 00:45:01 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2017-02-06 00:45:01 -0800
commit3c53449695626221978142cb1b0f6b53cdf99807 (patch)
tree1070c5c6bb60971b720eafebc8a122c35005417d /app-backup/genbackupdata/genbackupdata-1.9.ebuild
parentmedia-libs/mesa: update wayland dep. (diff)
downloadgentoo-3c53449695626221978142cb1b0f6b53cdf99807.tar.gz
gentoo-3c53449695626221978142cb1b0f6b53cdf99807.tar.bz2
gentoo-3c53449695626221978142cb1b0f6b53cdf99807.zip
app-backup/genbackupdata: new package, useful for backup testing.
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-backup/genbackupdata/genbackupdata-1.9.ebuild')
-rw-r--r--app-backup/genbackupdata/genbackupdata-1.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-backup/genbackupdata/genbackupdata-1.9.ebuild b/app-backup/genbackupdata/genbackupdata-1.9.ebuild
new file mode 100644
index 000000000000..bdc821665a4c
--- /dev/null
+++ b/app-backup/genbackupdata/genbackupdata-1.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit distutils-r1
+
+DESCRIPTION="Generate test data for backup software testing."
+HOMEPAGE="http://liw.fi/genbackupdata/"
+#SRC_URI="http://git.liw.fi/cgi-bin/cgit/cgit.cgi/$PN/snapshot/${P}.tar.gz"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/cliapp[${PYTHON_USEDEP}]
+ >=dev-python/ttystatus-0.31[${PYTHON_USEDEP}]
+ "
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ addwrite /proc/self/comm
+ distutils-r1_src_compile
+ emake genbackupdata.1
+}