summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-backup/holland-backup-mysqlhotcopy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-backup/holland-backup-mysqlhotcopy')
-rw-r--r--app-backup/holland-backup-mysqlhotcopy/Manifest1
-rw-r--r--app-backup/holland-backup-mysqlhotcopy/holland-backup-mysqlhotcopy-1.0.10.ebuild47
-rw-r--r--app-backup/holland-backup-mysqlhotcopy/metadata.xml10
3 files changed, 58 insertions, 0 deletions
diff --git a/app-backup/holland-backup-mysqlhotcopy/Manifest b/app-backup/holland-backup-mysqlhotcopy/Manifest
new file mode 100644
index 000000000000..a4d8dca18b99
--- /dev/null
+++ b/app-backup/holland-backup-mysqlhotcopy/Manifest
@@ -0,0 +1 @@
+DIST holland-1.0.10.tar.gz 449334 SHA256 c893be3dc77126125334dfa9eec404d7608a78a2bf88ec1d7ddc12ad7f7ed8d1 SHA512 5183ec73012edcaba50ef5cc9b892480d5f60301d01d17bd96c5490bd8e6ae42bd21abb6084e6665317b8025489981a02293cd583964f01e86459609b93e918f WHIRLPOOL fa8934c635f4347ffc6a327f6135d61ca26805d727fe4caca32ba9c23224062492553182e24d15fc59177787241903dd3409396c176fab2d55c34e9dcc5668e3
diff --git a/app-backup/holland-backup-mysqlhotcopy/holland-backup-mysqlhotcopy-1.0.10.ebuild b/app-backup/holland-backup-mysqlhotcopy/holland-backup-mysqlhotcopy-1.0.10.ebuild
new file mode 100644
index 000000000000..604f16ec7ab6
--- /dev/null
+++ b/app-backup/holland-backup-mysqlhotcopy/holland-backup-mysqlhotcopy-1.0.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Holland MySQL (MyISAM) Hotcopy Plugin"
+HOMEPAGE="http://www.hollandbackup.org/"
+
+MY_P="${P%%-*}-${P##*-}"
+
+SRC_URI="http://hollandbackup.org/releases/stable/${PV%.*}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ ~app-backup/holland-lib-common-${PV}[${PYTHON_USEDEP}]
+ ~app-backup/holland-lib-mysql-${PV}[${PYTHON_USEDEP}]
+"
+PDEPEND="~app-backup/holland-${PV}[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}/plugins/${PN//-/.}"
+
+python_install_all() {
+ use doc && local DOCS=( README docs/man/holland-mysqlhotcopy.rst )
+
+ distutils-r1_python_install_all
+
+ keepdir /etc/holland
+ keepdir /etc/holland/backupsets
+ keepdir /etc/holland/providers
+
+ insinto /etc/holland/backupsets
+ doins "${S}"/../../config/backupsets/examples/${PN##*-}.conf
+
+ insinto /etc/holland/providers
+ doins "${S}"/../../config/providers/${PN##*-}.conf
+
+ doman docs/man/holland-mysqlhotcopy.5
+}
diff --git a/app-backup/holland-backup-mysqlhotcopy/metadata.xml b/app-backup/holland-backup-mysqlhotcopy/metadata.xml
new file mode 100644
index 000000000000..02be8c5eb78f
--- /dev/null
+++ b/app-backup/holland-backup-mysqlhotcopy/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>