summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2016-12-31 04:48:18 +0100
committerMarc Schiffbauer <mschiff@gentoo.org>2016-12-31 04:48:46 +0100
commit3e2df91401ef1486c37d5bca197504a1e17d63ae (patch)
treebf5853df6afc4006cae60893cf53f023568d50d3 /app-backup/obnam/obnam-1.21.ebuild
parentsec-policy: Stabilize selinux policy 2.20161023-r3 (diff)
downloadgentoo-3e2df91401ef1486c37d5bca197504a1e17d63ae.tar.gz
gentoo-3e2df91401ef1486c37d5bca197504a1e17d63ae.tar.bz2
gentoo-3e2df91401ef1486c37d5bca197504a1e17d63ae.zip
app-backup/obnam: bump 1.20 to 1.21
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-backup/obnam/obnam-1.21.ebuild')
-rw-r--r--app-backup/obnam/obnam-1.21.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-backup/obnam/obnam-1.21.ebuild b/app-backup/obnam/obnam-1.21.ebuild
new file mode 100644
index 000000000000..46d86fb0af07
--- /dev/null
+++ b/app-backup/obnam/obnam-1.21.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit distutils-r1
+
+DESCRIPTION="A backup program that supports encryption and deduplication"
+HOMEPAGE="http://obnam.org/"
+SRC_URI="http://git.liw.fi/cgi-bin/cgit/cgit.cgi/obnam/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/cliapp[${PYTHON_USEDEP}]
+ dev-python/fuse-python[${PYTHON_USEDEP}]
+ dev-python/larch[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tracing[${PYTHON_USEDEP}]
+ dev-python/ttystatus[${PYTHON_USEDEP}]
+ "
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ addwrite /proc/self/comm
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+ find "${D}" -name "obnam-viewprof*" -delete
+ insinto /etc
+ doins "${FILESDIR}"/obnam.conf
+ keepdir /var/log/obnam
+}