summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-10-01 16:17:25 -0600
committerSam James <sam@gentoo.org>2023-10-10 04:03:06 +0100
commitf1b4319a7a0b19e01293ebaa1494db4ae7dae192 (patch)
treed7124fb5d51a8bddb83163674c7186fb74114adb /app-backup/simplebackup
parentapp-backup/rdup: update EAPI 6 -> 8 (diff)
downloadgentoo-f1b4319a7a0b19e01293ebaa1494db4ae7dae192.tar.gz
gentoo-f1b4319a7a0b19e01293ebaa1494db4ae7dae192.tar.bz2
gentoo-f1b4319a7a0b19e01293ebaa1494db4ae7dae192.zip
app-backup/simplebackup: update EAPI 6 -> 8
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-backup/simplebackup')
-rw-r--r--app-backup/simplebackup/simplebackup-1.8.1-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-backup/simplebackup/simplebackup-1.8.1-r2.ebuild b/app-backup/simplebackup/simplebackup-1.8.1-r2.ebuild
new file mode 100644
index 000000000000..aabaaaffac32
--- /dev/null
+++ b/app-backup/simplebackup/simplebackup-1.8.1-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit prefix
+
+DESCRIPTION="Cross-platform backup program"
+HOMEPAGE="https://migas-sbackup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/migas-sbackup/${P}.tar.gz"
+S="${WORKDIR}/${P}/unix"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sasl"
+
+RDEPEND="
+ dev-lang/perl
+ sasl? ( dev-perl/Authen-SASL )
+"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ hprefixify simplebackup.pl
+ newbin simplebackup.pl simplebackup
+ dodoc ../unix_readme.txt
+}