summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2019-12-20 02:05:52 +0000
committerYixun Lan <dlan@gentoo.org>2019-12-20 02:09:12 +0000
commit8f9333a09189a9ae5629a3325cd04fe404c529d2 (patch)
treebe53637e8cb4697f548e81dc4d9ccb3f733e7655 /app-backup/snapper
parentdev-lang/rust-bin: drop 1.36.0 (diff)
downloadgentoo-8f9333a09189a9ae5629a3325cd04fe404c529d2.tar.gz
gentoo-8f9333a09189a9ae5629a3325cd04fe404c529d2.tar.bz2
gentoo-8f9333a09189a9ae5629a3325cd04fe404c529d2.zip
app-backup/snapper: version bump, 0.8.5
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-backup/snapper')
-rw-r--r--app-backup/snapper/Manifest1
-rw-r--r--app-backup/snapper/snapper-0.8.5.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-backup/snapper/Manifest b/app-backup/snapper/Manifest
index 157e7ed61309..05c5e18d633b 100644
--- a/app-backup/snapper/Manifest
+++ b/app-backup/snapper/Manifest
@@ -1,3 +1,4 @@
DIST snapper-0.5.6.tar.bz2 580047 BLAKE2B 3b945acbf734db1925dad5515323a64a2c08ee8226a593025f9160e0d1b1140734b2b498d036256946159900b50fec8567147dc0a974c281be747e977bcbd05b SHA512 392427d097cbe221bf7ca0ae20bc065dffaa4d0017ed750c41748d71128fc7ce054bb4425d6dbed7308a530df71815f80f56e60d72aab17ef3e0a16f3b3ba47e
DIST snapper-0.8.3.tar.bz2 592405 BLAKE2B 7694a6c79e4beaf307801ccd97a6cd1c3c6078e68653e9a5eda3ddcd087ef32f8302d380ee550ac5c7259c7e23ddb15bf9f2d01267d5691fe10e0335d490a258 SHA512 409a8464c10905da1407ce3bf68ad1d7df53480da4f8e98e40ef4ee5cb5170bb99c07fabb367510eb2a19744a827dc9a33cf74de05fbb2fc5f22fe3dc4adef6d
DIST snapper-0.8.4.tar.bz2 594555 BLAKE2B b176420be06dea2dca73fafbebb362bb27d9b793868f84466dae020cea9d1c61c7a3896de6e0701d1e924eed8c13b1b11a7bbc3047ca41c9aaee260a438ddce3 SHA512 9e3708a2b015470798731e105ab843f21c5273f0f2f4e183afde538ad4998892c4d79996e1963e74d0a09d10b9b3057faed5e2f501a1d9a5a4b1fa36ba88bb7e
+DIST snapper-0.8.5.tar.bz2 595516 BLAKE2B 4cf59fa5098f91281bae98476b30c21532df5035ee7ed66fd07e279174bd5da902e1e5af845ab92f217146a6c420620ff464c9705fd06b430bbf3566aa9ae484 SHA512 496b09f4878cbc82c791f35467735e321fdcbd2bc478fac918394b9f6718b7de5cf719567a317b09e88e9af43f2b8791c4d691b2db33343dfecb01544b809590
diff --git a/app-backup/snapper/snapper-0.8.5.ebuild b/app-backup/snapper/snapper-0.8.5.ebuild
new file mode 100644
index 000000000000..90bf21dacc24
--- /dev/null
+++ b/app-backup/snapper/snapper-0.8.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd bash-completion-r1
+
+DESCRIPTION="Command-line program for btrfs and lvm snapshot management"
+HOMEPAGE="http://snapper.io/"
+SRC_URI="ftp://ftp.suse.com/pub/projects/snapper/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lvm pam xattr"
+
+RDEPEND="dev-libs/boost:=[threads]
+ dev-libs/libxml2
+ dev-libs/icu:=
+ sys-apps/acl
+ sys-apps/dbus
+ sys-apps/util-linux
+ >=sys-fs/btrfs-progs-3.17.1
+ sys-libs/zlib
+ virtual/libintl
+ lvm? ( sys-fs/lvm2 )
+ pam? ( sys-libs/pam )
+ xattr? ( sys-apps/attr )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/cron-confd.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e "s,/usr/lib/systemd/system,$(systemd_get_systemunitdir),g" \
+ -i data/Makefile.* \
+ || die "Failed to fix systemd services and timers installation path"
+}
+
+src_configure() {
+ # ext4 code does not work anymore
+ # snapper does not build without btrfs
+ local myeconfargs=(
+ --with-conf="/etc/conf.d"
+ --docdir="/usr/share/doc/${PF}"
+ --disable-zypp
+ --enable-rollback
+ --disable-ext4
+ --enable-btrfs
+ $(use_enable lvm)
+ $(use_enable pam)
+ $(use_enable xattr xattrs)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ # Existing configuration file required to function
+ newconfd data/sysconfig.snapper snapper
+ find "${D}" -name '*.la' -delete || die
+ newbashcomp "${FILESDIR}"/${PN}.bash ${PN}
+}
+
+pkg_postinst() {
+ elog "In order to use Snapper, you need to set up"
+ elog "at least one config first. To do this, run:"
+ elog "snapper create-config <subvolume>"
+ elog "For more information, see man (8) snapper or"
+ elog "http://snapper.io/documentation.html"
+}