summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2023-05-11 12:51:14 -0400
committerRichard Freeman <rich0@gentoo.org>2023-05-11 12:51:14 -0400
commit124091a1f51d442e286e7de91a2b9809e4d7b519 (patch)
tree3d2045aa99a1d867843e97b467531102e7f68291 /app-backup
parentsys-libs/kpmcore: drop 23.04.0 (diff)
downloadgentoo-124091a1f51d442e286e7de91a2b9809e4d7b519.tar.gz
gentoo-124091a1f51d442e286e7de91a2b9809e4d7b519.tar.bz2
gentoo-124091a1f51d442e286e7de91a2b9809e4d7b519.zip
app-backup/duplicity: add 1.2.3
Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-1.2.3.ebuild51
-rw-r--r--app-backup/duplicity/files/duplicity-1.2.3-fix-docs-cmd.patch20
3 files changed, 72 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index 843f170663e8..275daa9758d4 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -2,3 +2,4 @@ DIST duplicity-0.8.23.tar.gz 1385252 BLAKE2B 63042486e6e17d2d93af72f617990c87976
DIST duplicity-1.0.0.tar.gz 1381405 BLAKE2B 5de886ca767c01097bc4954c2dc5e6c222c7f9a70f03476d3f8b749cd2d2c25a93458f656e9847cdb0a5cba27bc9466fd825f9b28cbdb593e602cec62876eb9a SHA512 27601f1e83fe685b94caf3703bf8001111efcf0e0af371f3c5434354c55bffba9d3dbd9b48b11808557154c61acfa7c19700dd1f45b10c471c570d85f145b7dd
DIST duplicity-1.0.1.tar.gz 1928618 BLAKE2B f7ffdd488e42219b66b6174dbb944283d02910f57cae9fcf849e8f5363986664a49ba7e316d6b3efdce89deec7e4c6a65a95bcb365fa23b928244b5e8f29d48b SHA512 dab8341b990b1899de6080f2539681f0a84f1875fabf04ccd68908e8dcdf55cd31f26d1431488b49ac6b048a1e7ff2e0a0afa27f6eccfd6a20f47dd7193b4563
DIST duplicity-1.2.2.tar.gz 1427493 BLAKE2B d30f91054c59695483a60a684ebc11440b1a490dc635fdc856d7e3e75d7c3b8bc3f8680ecec0af435fe3064c292c6ff0db392e6bb33c682e9527561196e842e1 SHA512 5da4addd0742afa93c62c506f49235b396a7d4bb6576bfd5ec223e04936072ef92e874c533f0f7ece3c1460bf017c2e1875d4ed5c08181113e2509dd28b4521b
+DIST duplicity-1.2.3.tar.gz 1438570 BLAKE2B 12afa69f537d2207343c1638df1cf69ad3e170b2f1368e5d8b86716ccc67564834798e2076a90f021bae8f1d8574ff50f0615fd873cdcddf1399349974d8d4c2 SHA512 d2a31b4ed2c0a188d6d2ac543d3d4a474b4c10028a3005b26f57bd57e8c7441eb96e361aa9805fedc6aa09e76e86d3d1e99800669dfb7b2510233e2c0aba15de
diff --git a/app-backup/duplicity/duplicity-1.2.3.ebuild b/app-backup/duplicity/duplicity-1.2.3.ebuild
new file mode 100644
index 000000000000..fc665542a7f1
--- /dev/null
+++ b/app-backup/duplicity/duplicity-1.2.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_10 python3_11 )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="https://duplicity.gitlab.io/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto3[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs-cmd.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/files/duplicity-1.2.3-fix-docs-cmd.patch b/app-backup/duplicity/files/duplicity-1.2.3-fix-docs-cmd.patch
new file mode 100644
index 000000000000..03b090d0545e
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-1.2.3-fix-docs-cmd.patch
@@ -0,0 +1,20 @@
+--- duplicity-1.2.3/setup.py.orig 2023-05-11 12:33:14.480474449 -0400
++++ duplicity-1.2.3/setup.py 2023-05-11 12:33:19.204538723 -0400
+@@ -95,17 +95,6 @@
+ u'bin/rdiffdir.1'
+ ]
+ ),
+- (u'share/doc/duplicity-%s' % Version,
+- [
+- u'CHANGELOG.md',
+- u'CONTRIBUTING.md',
+- u'COPYING',
+- u'README.md',
+- u'README-LOG.md',
+- u'README-REPO.md',
+- u'README-TESTING.md',
+- ],
+- ),
+ ]
+
+ # short circuit fot READTHEDOCS