summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-01 03:42:34 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:54:01 +0100
commit15337d9ada09a6e77fcf8b717b5d182166a071c5 (patch)
tree2059b2c2490e1196128164c47332344ba82d3221 /app-backup
parentapp-backup/pdumpfs: eutils -> epatch (diff)
downloadgentoo-15337d9ada09a6e77fcf8b717b5d182166a071c5.tar.gz
gentoo-15337d9ada09a6e77fcf8b717b5d182166a071c5.tar.bz2
gentoo-15337d9ada09a6e77fcf8b717b5d182166a071c5.zip
app-backup/spideroak-bin: desktop++, misc fixes (|| die, etc)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/spideroak-bin/spideroak-bin-7.5.0-r1.ebuild35
1 files changed, 19 insertions, 16 deletions
diff --git a/app-backup/spideroak-bin/spideroak-bin-7.5.0-r1.ebuild b/app-backup/spideroak-bin/spideroak-bin-7.5.0-r1.ebuild
index bd12c7b9d6fd..9b91aa577c3c 100644
--- a/app-backup/spideroak-bin/spideroak-bin-7.5.0-r1.ebuild
+++ b/app-backup/spideroak-bin/spideroak-bin-7.5.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-inherit eutils unpacker
+inherit desktop unpacker
DESCRIPTION="Secure free online backup, storage, and sharing system"
HOMEPAGE="https://spideroak.com"
@@ -46,47 +46,50 @@ src_prepare() {
# Set RPATH for preserve-libs handling (bug #400979).
cd "${S}/opt/SpiderOakONE/lib" || die
local x
- for x in `find` ; do
+ for x in $(find) ; do
# Use \x7fELF header to separate ELF executables and libraries
[[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
patchelf --set-rpath '$ORIGIN' "${x}" || \
die "patchelf failed on ${x}"
done
- #Remove the libraries that break compatibility in modern systems
- #SpiderOak will use the system libs instead
- rm -f "${S}/opt/SpiderOakONE/lib/libstdc++.so.6"
- rm -f "${S}/opt/SpiderOakONE/lib/libgcc_s.so.1"
- rm -f "${S}/opt/SpiderOakONE/lib/libpng12.so.0"
- rm -f "${S}/opt/SpiderOakONE/lib/libz.so.1"
+ # Remove the libraries that break compatibility in modern systems
+ # SpiderOak will use the system libs instead
+ rm -f "${S}/opt/SpiderOakONE/lib/libstdc++.so.6" || die
+ rm -f "${S}/opt/SpiderOakONE/lib/libgcc_s.so.1" || die
+ rm -f "${S}/opt/SpiderOakONE/lib/libpng12.so.0" || die
+ rm -f "${S}/opt/SpiderOakONE/lib/libz.so.1" || die
eapply_user
}
src_install() {
- #install the wrapper script
+ # Install the wrapper script
exeinto /usr/bin
doexe usr/bin/SpiderOakONE
# inotify_dir_watcher needs to be marked executable, bug #453266
#chmod a+rx opt/SpiderOakONE/lib/inotify_dir_watcher
- #install the executable
+ # Install the executable
exeinto /opt/SpiderOakONE/lib
doexe opt/SpiderOakONE/lib/SpiderOakONE
doexe opt/SpiderOakONE/lib/inotify_dir_watcher
- rm -f opt/SpiderOakONE/lib/{SpiderOakONE,inotify_dir_watcher}
+ rm -f opt/SpiderOakONE/lib/{SpiderOakONE,inotify_dir_watcher} || die
- #install the prebundled libraries
+ # Install the prebundled libraries
insinto /opt/SpiderOakONE
doins -r opt/SpiderOakONE/lib
- #install the config files
- use dbus || rm -rf etc/dbus-1
+ # Install the config files
+ if ! use dbus; then
+ rm -rf etc/dbus-1 || die
+ fi
+
insinto /
doins -r etc
- #install the manpage
+ # Install the manpage
doman usr/share/man/man1/SpiderOakONE.1.gz
if use X; then