summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-05 05:57:08 +0100
committerSam James <sam@gentoo.org>2023-05-05 06:03:25 +0100
commit1785c633059ec10b2b51daa9b0737208d9337c00 (patch)
treee7721c2ae87e7400c97d23c42ec72b5032b0e90c /app-backup
parentapp-arch/brotli: Set DISTUTILS_EXT=1 (diff)
downloadgentoo-1785c633059ec10b2b51daa9b0737208d9337c00.tar.gz
gentoo-1785c633059ec10b2b51daa9b0737208d9337c00.tar.bz2
gentoo-1785c633059ec10b2b51daa9b0737208d9337c00.zip
app-backup/tarsnap: add 1.0.40
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/tarsnap/Manifest1
-rw-r--r--app-backup/tarsnap/tarsnap-1.0.40.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-backup/tarsnap/Manifest b/app-backup/tarsnap/Manifest
index a136bb15a19b..ea0b05c8f381 100644
--- a/app-backup/tarsnap/Manifest
+++ b/app-backup/tarsnap/Manifest
@@ -1 +1,2 @@
DIST tarsnap-autoconf-1.0.39.tgz 641089 BLAKE2B 4da7fa75c2a6df3186fac4f39a511532ae866c287a2bdc8dcc22049b53fcc903305f84fae9258793bc0c7a47b208d0bf2995143ee7b4296a35b4ca41d65d9a09 SHA512 dec8a72144a3a7fd42b006933c904b812894ca9fe2c57ecc4fbba817b9b49c8f15517530a00b0c3a9897e3182b4d9aee525334537806a9c4f7308086678fa2b4
+DIST tarsnap-autoconf-1.0.40.tgz 723380 BLAKE2B a794bb9bae3637c36841ad4bb0fa1c0e1c39a78ac2dc92f18cbe7dfe1036aa861f5421751dd8a85948dcb101ecb81f2177e844609b289238abd9a8448ba1655a SHA512 a4910c5cbea4a71218638703ba3140e5536a2c9bb7f35007115a7ae4a87fcd07b1be91d88e49240ee8db39be326bac049c0893c1406f215123d55a13b7b57941
diff --git a/app-backup/tarsnap/tarsnap-1.0.40.ebuild b/app-backup/tarsnap/tarsnap-1.0.40.ebuild
new file mode 100644
index 000000000000..ebf35c72ced2
--- /dev/null
+++ b/app-backup/tarsnap/tarsnap-1.0.40.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 toolchain-funcs
+
+DESCRIPTION="Online backups for the truly paranoid"
+HOMEPAGE="https://www.tarsnap.com/"
+SRC_URI="https://www.tarsnap.com/download/${PN}-autoconf-${PV}.tgz"
+S="${WORKDIR}"/${PN}-autoconf-${PV}
+
+LICENSE="tarsnap"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acl bzip2 lzma xattr"
+
+RDEPEND="
+ dev-libs/openssl:=
+ sys-fs/e2fsprogs
+ sys-libs/zlib
+ acl? ( sys-apps/acl )
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ xattr? ( sys-apps/attr )
+"
+# Required for "magic.h"
+DEPEND="
+ ${RDEPEND}
+ virtual/os-headers
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.39-respect-AR.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable xattr)
+ $(use_enable acl)
+ $(use_with bzip2 bz2lib)
+ --without-lzmadec
+ $(use_with lzma)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+ dobashcomp misc/bash_completion.d/*
+}