summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2021-05-02 12:37:59 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-05-19 09:20:01 +0300
commit471288432a1a5efbcf8f05080178c6bc5b46bcd1 (patch)
treeffd14252fd5266aca7a920963c9e00cd57ecdd6b /app-backup
parentmail-filter/milter-regex: remove unused file (diff)
downloadgentoo-471288432a1a5efbcf8f05080178c6bc5b46bcd1.tar.gz
gentoo-471288432a1a5efbcf8f05080178c6bc5b46bcd1.tar.bz2
gentoo-471288432a1a5efbcf8f05080178c6bc5b46bcd1.zip
app-backup/dar: new version 2.7.0
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20648 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/dar/Manifest1
-rw-r--r--app-backup/dar/dar-2.7.0.ebuild90
-rw-r--r--app-backup/dar/metadata.xml1
3 files changed, 92 insertions, 0 deletions
diff --git a/app-backup/dar/Manifest b/app-backup/dar/Manifest
index 6b46f2f499cf..b962575d298e 100644
--- a/app-backup/dar/Manifest
+++ b/app-backup/dar/Manifest
@@ -1,2 +1,3 @@
DIST dar-2.6.13.tar.gz 2148732 BLAKE2B 51de01793dead832209671569f8054b1de3b5fa810c786ae675207b6dc3e639a5c036896e1688e017b222fbaa6c011494a9d43b3bb2b16570a38e291f893b73f SHA512 f0f853db6e15f5abfabf87be06a1c374662c7fa7e1140eaaeef3e8c8c4d0049a00a8e74409d6805ea3ae5b2f3171f2eba27459e8acb4438c467c4f0bd0825c0c
DIST dar-2.6.14.tar.gz 2148023 BLAKE2B 36653d798d1da9cd87e84d2301b9f1fd657e92d1eee91ec1efadb54e94638860103c5e509479a2da846d432328e0a93ae92e1a4d23b6956ca55341ef767fe9a8 SHA512 2b116929fcc192ffee0c266959902b45dc9982ba77e017b3217715e0c63d1574d64083ca55a63e0bb6390e8955c41ca8b09da63934826fe4f0471a63ea739550
+DIST dar-2.7.0.tar.gz 2285856 BLAKE2B 194e9fe2345bdccdb053996b109fe4efb886e23b69d440f7ac2b545c1ce2f241c7f24c56d7b68bde904b8e1a85df20716b63068a6c471c71a7569921eb06aa1f SHA512 0e207c244f6700860a84217069774162b7b56c95e5c0955813fbd96d37a3fe1fa126cab05bab0a21b3e9eab335c10961daf243024fdc35f6276468bd549d49cb
diff --git a/app-backup/dar/dar-2.7.0.ebuild b/app-backup/dar/dar-2.7.0.ebuild
new file mode 100644
index 000000000000..0b4d6b7ae696
--- /dev/null
+++ b/app-backup/dar/dar-2.7.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE="argon2 curl dar32 dar64 doc gcrypt gpg lzo nls rsync threads xattr"
+
+RESTRICT="test" # need to be run as root
+
+RDEPEND="
+ app-arch/bzip2:=
+ app-arch/xz-utils:=
+ sys-libs/libcap
+ >=sys-libs/zlib-1.2.3:=
+ argon2? ( app-crypt/argon2 )
+ curl? ( net-misc/curl )
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ gpg? ( app-crypt/gpgme )
+ lzo? ( dev-libs/lzo:= )
+ rsync? ( net-libs/librsync:= )
+ threads? ( dev-libs/libthreadar:= )
+ xattr? ( sys-apps/attr:= )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ nls? (
+ sys-devel/gettext
+ virtual/libintl
+ )
+"
+
+REQUIRED_USE="?? ( dar32 dar64 )
+ gpg? ( gcrypt )"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+src_configure() {
+ # configure.ac is totally funked up regarding the AC_ARG_ENABLE
+ # logic.
+ # For example "--enable-dar-static" causes configure to DISABLE
+ # static builds of dar.
+ # Do _not_ use $(use_enable) until you have verified that the
+ # logic has been fixed by upstream.
+ local myconf=(
+ --disable-dar-static
+ --disable-python-binding
+ --disable-static
+ --disable-upx
+ $(usex argon2 '' --disable-libargon2-linking)
+ $(usex curl '' --disable-libcurl-linking)
+ $(usex dar32 --enable-mode=32 '')
+ $(usex dar64 --enable-mode=64 '')
+ $(usex doc '' --disable-build-html)
+ $(usex gcrypt '' --disable-libgcrypt-linking)
+ $(usex gpg '' --disable-gpgme-linking)
+ $(usex lzo '' --disable-liblzo2-linking)
+ $(usex nls '' --disable-nls)
+ $(usex rsync '' --disable-librsync-linking)
+ $(usex threads '' --disable-threadar)
+ $(usex xattr '' --disable-ea-support)
+ )
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
+
+ einstalldocs
+
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+ # Bug 729150
+ rm "${ED}/usr/share/doc/${PF}/html/samples/MyBackup.sh.tar.gz" || die
+}
diff --git a/app-backup/dar/metadata.xml b/app-backup/dar/metadata.xml
index b601da091bec..2715a3d89764 100644
--- a/app-backup/dar/metadata.xml
+++ b/app-backup/dar/metadata.xml
@@ -16,6 +16,7 @@ compression, ATTR/ACL support. DAR also supports Pipes for remote
operations, including with ssh.
</longdescription>
<use>
+ <flag name="argon2">Enable password hashing algorithm from <pkg>app-crypt/argon2</pkg></flag>
<flag name="dar32">Enables --enable-mode=32 option, which replace infinite
by 32 bit integers</flag>
<flag name="dar64">Enables --enable-mode=64 option, which replace infinite