summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-05-11 13:29:57 +0100
committerMarek Szuba <marecki@gentoo.org>2023-05-11 13:29:57 +0100
commit94340d71baa8d709c0cf529a7ca95120654bba8c (patch)
tree57b800111818dabe1aad7981ce4c585ce728e39e /app-backup
parentmedia-sound/easyeffects: stabilize 7.0.3 for amd64 (diff)
downloadgentoo-94340d71baa8d709c0cf529a7ca95120654bba8c.tar.gz
gentoo-94340d71baa8d709c0cf529a7ca95120654bba8c.tar.bz2
gentoo-94340d71baa8d709c0cf529a7ca95120654bba8c.zip
app-backup/borgmatic: add 1.7.12
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.7.12.ebuild74
-rw-r--r--app-backup/borgmatic/files/borgmatic-1.7.12-tests_flexmock.patch23
3 files changed, 98 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index badfb50b3b04..3c218c9fc4cc 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,2 +1,3 @@
DIST borgmatic-1.7.11.tar.gz 365247 BLAKE2B a06737c48722fdf24efca76d40f6b413f39635b4137685d6279bf7a7dd002fadef28dab35a503fabf872c732a0f32fbff8c791fa9b4602299937aeae568d6137 SHA512 cedca889cd409e92484c15240fd8da91c655f81e38c6672d25e44feedc4adf6594281d92f7072fd11edc5c9f8589098226a3520e71e3441ee7a7acf97e1b2daa
+DIST borgmatic-1.7.12.tar.gz 371090 BLAKE2B eb06d88320f2c49721938c756d637b6ce463192260ac734303079095c693cadde68805356249fdad86738bed8ea0afa2e7a5c5de3c68bbedba2162e1cb445cdd SHA512 6688eb48d9ac82e9c43816aebab36b6dc011132e9f90591b7add423743a7305f55ca60f3f02f983c2d5d2e86e2429da62aec2508fac472b05334a025a308c325
DIST borgmatic-1.7.8.tar.gz 350233 BLAKE2B 3fcd392983f73ec5e97f0dc6b96e211d7f1e1d1a4ce95c635c675cf043e796925df53c30c1e4f8eb1a095d9ec5ff81e90edee5ff2576f4683053d3108004afd9 SHA512 bcc65fdb7ea1171fb61deda9b1f69a00596e1e10a99508d336977b694bd8f93d74837aad9211bf1065b785220aaf1460a3ea403bf23fa4873d1bf4c6b4016525
diff --git a/app-backup/borgmatic/borgmatic-1.7.12.ebuild b/app-backup/borgmatic/borgmatic-1.7.12.ebuild
new file mode 100644
index 000000000000..128d6c2e7a7c
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.7.12.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.7.3-systemd_service_bin_path.patch
+ "${FILESDIR}"/${PN}-1.7.12-tests_flexmock.patch
+)
+
+# A fragile test whose only purpose is to make sure the NEWS file
+# has been updated for the current version.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " generate-borgmatic-config"
+ else
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.7.11; then
+ ewarn "Since version 1.7.11 ${PN} defaults to a different way of selecting archives for multi-archive actions."
+ ewarn "For details, please see"
+ ewarn
+ ewarn " https://torsion.org/borgmatic/docs/how-to/make-per-application-backups/#archive-naming"
+ ewarn
+ break
+ fi
+ done
+ fi
+ elog
+ elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
+}
diff --git a/app-backup/borgmatic/files/borgmatic-1.7.12-tests_flexmock.patch b/app-backup/borgmatic/files/borgmatic-1.7.12-tests_flexmock.patch
new file mode 100644
index 000000000000..5c41f9a7e701
--- /dev/null
+++ b/app-backup/borgmatic/files/borgmatic-1.7.12-tests_flexmock.patch
@@ -0,0 +1,23 @@
+From ebe5c5e83903685742a39ae63b779d7a64527cff Mon Sep 17 00:00:00 2001
+From: polyzen <polyzen@noreply.torsion.org>
+Date: Fri, 14 Apr 2023 01:01:31 +0000
+Subject: [PATCH] Fix "TypeError: 'module' object is not callable" in
+ test_commands.py
+
+--- a/tests/integration/borg/test_commands.py
++++ b/tests/integration/borg/test_commands.py
+@@ -1,6 +1,6 @@
+ import copy
+
+-import flexmock
++from flexmock import flexmock
+
+ import borgmatic.borg.info
+ import borgmatic.borg.list
+@@ -105,4 +105,4 @@ def test_display_archives_info_command_does_not_duplicate_flags_or_raise():
+
+ borgmatic.borg.info.display_archives_info(
+ 'repo', {}, '2.3.4', fuzz_argument(arguments, argument_name)
+- )
++ )
+\ No newline at end of file