summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2020-01-13 14:33:16 -0500
committerRichard Freeman <rich0@gentoo.org>2020-01-13 14:33:34 -0500
commitaf333a210fda1b8e791a52979aa3f058cd2e6265 (patch)
treec8f3ff86ecc787ce35bc83adfa082e36b6004fd4 /app-backup
parentnet-libs/libproxy: Drop USE python, python3 has a major runtime issue (diff)
downloadgentoo-af333a210fda1b8e791a52979aa3f058cd2e6265.tar.gz
gentoo-af333a210fda1b8e791a52979aa3f058cd2e6265.tar.bz2
gentoo-af333a210fda1b8e791a52979aa3f058cd2e6265.zip
app-backup/duplicity: bump, cleanup test logic
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-0.8.09.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index 770f337566f8..07c65d3ac03f 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -1,3 +1,4 @@
DIST duplicity-0.7.10.tar.gz 1543523 BLAKE2B a38c5310d6949d36f74620ef617f790943284d7219168e0e49ed13834ab72f5c0d057ef59454e58a25be3a9e28d9627d60c007aab373e150afca08248d79aab6 SHA512 d04273384749c88d0a4f46bc1dcdcbb945ec1a78fb21064f12f0ca6c92cc73ad36fc3149461dbe0a660cd752a1147b2fa5d2b4056a5414c7790747eb5983e0bd
DIST duplicity-0.7.12.tar.gz 1552442 BLAKE2B 4a7d0609748bffa147994a4abdb88bc0d62905c1423dc91caa4b8e5bb0c5953e26df72f647697685cfa3caed3741658d00d1a2b62b8c47bb1ac61da8973df9ca SHA512 8a532e7bb548c170184666a0ba2b41a15f3002c14edd64b1b1eb4df862647fc6dfde797d6ecf38e326d7c160c31ff521baf351e520835495e1d0e2ddbdb19f0f
DIST duplicity-0.7.19.tar.gz 1727321 BLAKE2B 6441a2ce777b3b08c52ede8602a73080be372dec1c1788441c7e7135533aeeb3be48012db4bdfc2a78c7ca23d368637ccc7aa0f0361369ac9f42c00a1541e023 SHA512 26d1724a635c368e04f2a94f974ef6962c52b23345db59af3343e7221295caa0215ae119fff6ab44daa4622236683eb9d3dae742bf0d4cf08c02e3f63071001b
+DIST duplicity-0.8.09.tar.gz 1856764 BLAKE2B b5d0dd3270c237694000dc36a65a4293c43264edf933a195692d2847d008a898d5cf95c0b21b285503023ef8885278485cebabc2d2b7094ae65e13d277c80e5a SHA512 e4045a1c1adbf0927ee5325f02b79e7c0b38034080be4b563f20f1af593c8c1943a772fe7f212730e60f7c7cee93756426fe769a62050d42651fd1af7f6ba50a
diff --git a/app-backup/duplicity/duplicity-0.8.09.ebuild b/app-backup/duplicity/duplicity-0.8.09.ebuild
new file mode 100644
index 000000000000..01193189c3e0
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.8.09.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_6)
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}