summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2021-02-25 14:54:06 -0500
committerRichard Freeman <rich0@gentoo.org>2021-02-25 14:54:06 -0500
commitcb0a7d5e65a46215b0a3a17528662ca27b988256 (patch)
tree4bc6befb4ebc4ac19802243a495fc81f6de6ae35 /app-backup
parentapp-backup/duplicity: amd64 stable (diff)
downloadgentoo-cb0a7d5e65a46215b0a3a17528662ca27b988256.tar.gz
gentoo-cb0a7d5e65a46215b0a3a17528662ca27b988256.tar.bz2
gentoo-cb0a7d5e65a46215b0a3a17528662ca27b988256.zip
app-backup/duplicity: bump, update python support
Fixes: https://bugs.gentoo.org/768777 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-0.8.18.ebuild51
-rw-r--r--app-backup/duplicity/files/duplicity-0.8.18-fix-docs-cmd.patch28
3 files changed, 80 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index 20beea1a5d8c..ae954e24e248 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -1,3 +1,4 @@
DIST duplicity-0.8.15.tar.gz 1482647 BLAKE2B e1ddd4232611ad5fcf8faa5135c925aef68a21eb9dec50de7194562a0d4871e9c58132faf9340f71367025dcc84cbc6f1aae69bd37cae294d4200a8ca8b796b3 SHA512 2d048377c839ae56fc2828997c9aa7ba8c339e815e1e2ae738652037508ec276a2c72583687da34408fadd4839011e242b51bc73cca954227fc51db5683c258c
DIST duplicity-0.8.16.tar.gz 1470714 BLAKE2B c9b2df3a7f008d44595b76d5f1d86ef53996d3ad788415e3a0fa122a7246bb5ae92e73be5079b3cef9a9a93a0b106f3be6405882028d79dc49194276a7c8f4a7 SHA512 67e8fe7d5db7da82d82f24892d721e32cd63fcdb8bbc5e60508af06e4c9b637f593ce0b1902c31433c92ed97035880e44368e9a461ad197511171f67de937f73
DIST duplicity-0.8.17.tar.gz 1351433 BLAKE2B 39c87c421bb8a4bf27e60c16b6dde559ed4468a1062f02623d8e37deb62e63101b6fb5524e5a991139d39422cab2803b89007bf1ca5819817ab3b53d5318b88c SHA512 6f9f6b45953d2bc7ed403d68bdc419f384e07f831c783af720f15f88b100f5becb3f83f65cfc715b02686c24d18c5ec8f80c27789d1ec01cdc8efefa7590c211
+DIST duplicity-0.8.18.tar.gz 1352646 BLAKE2B 9703ad0780d6bd7db970941f529192132f1b7c138c72831cfdeb1b703dc9d952e28cf453a77a62babc872ec57d9193fa7293607401e278d12ec8143f779d2a60 SHA512 fd9dc472e4145725de343a3195ca8c898570ec492d46bc385d354c40b2c31e7c0da1f6e15e2a4a391d35926ae77e854992f4c973e55b072006c3f6489e27408f
diff --git a/app-backup/duplicity/duplicity-0.8.18.ebuild b/app-backup/duplicity/duplicity-0.8.18.ebuild
new file mode 100644
index 000000000000..4b901f06dcdb
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.8.18.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="https://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/$(ver_cut 1-3)/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs-cmd.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/files/duplicity-0.8.18-fix-docs-cmd.patch b/app-backup/duplicity/files/duplicity-0.8.18-fix-docs-cmd.patch
new file mode 100644
index 000000000000..a0fce6b2c5d8
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-0.8.18-fix-docs-cmd.patch
@@ -0,0 +1,28 @@
+--- duplicity-0.8.17/setup.py 2020-11-24 19:32:40.089024404 -0500
++++ duplicity-0.8.17/setup.py 2020-11-24 19:33:32.326309755 -0500
+@@ -93,17 +93,6 @@
+ u'bin/rdiffdir.1'
+ ]
+ ),
+- (u'share/doc/duplicity-%s' % Version,
+- [
+- u'AUTHORS',
+- u'CHANGELOG.md',
+- u'COPYING',
+- u'README.md',
+- u'README-LOG.md',
+- u'README-REPO.md',
+- u'README-TESTING.md',
+- ],
+- ),
+ ]
+
+ if not os.environ.get(u'READTHEDOCS') == u'True':
+@@ -339,7 +328,6 @@
+ ],
+ test_suite=u"testing",
+ cmdclass={
+- u"build_scripts": BuildScriptsCommand,
+ u"install": InstallCommand,
+ u"install_data": InstallDataCommand,
+ u"sdist": SdistCommand,