summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2021-03-06 16:29:27 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-03-12 13:29:06 +0200
commiteabc7b7cbc5bedb05f248a3b8c0d5d66ba5cdce3 (patch)
treef27e506d096855a320156076e9f312f72c29f7d6 /app-backup
parentapp-backup/dar: don't install compressed files (diff)
downloadgentoo-eabc7b7cbc5bedb05f248a3b8c0d5d66ba5cdce3.tar.gz
gentoo-eabc7b7cbc5bedb05f248a3b8c0d5d66ba5cdce3.tar.bz2
gentoo-eabc7b7cbc5bedb05f248a3b8c0d5d66ba5cdce3.zip
app-backup/dar: remove USE static and static-libs
Closes: https://bugs.gentoo.org/767454 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/dar/dar-2.6.13-r1.ebuild57
1 files changed, 19 insertions, 38 deletions
diff --git a/app-backup/dar/dar-2.6.13-r1.ebuild b/app-backup/dar/dar-2.6.13-r1.ebuild
index c343b6ed0566..d082367d6a58 100644
--- a/app-backup/dar/dar-2.6.13-r1.ebuild
+++ b/app-backup/dar/dar-2.6.13-r1.ebuild
@@ -12,47 +12,38 @@ SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
-IUSE="curl dar32 dar64 doc gcrypt gpg lzo nls rsync static static-libs xattr"
+IUSE="curl dar32 dar64 doc gcrypt gpg lzo nls rsync xattr"
RESTRICT="test" # need to be run as root
RDEPEND="
+ app-arch/bzip2:=
+ app-arch/xz-utils:=
+ sys-libs/libcap
>=sys-libs/zlib-1.2.3:=
- !static? (
- app-arch/bzip2:=
- app-arch/xz-utils:=
- sys-libs/libcap
- curl? ( net-misc/curl )
- gcrypt? ( dev-libs/libgcrypt:0= )
- gpg? ( app-crypt/gpgme )
- lzo? ( dev-libs/lzo:= )
- rsync? ( net-libs/librsync:= )
- xattr? ( sys-apps/attr:= )
- )"
-
-DEPEND="
- ${RDEPEND}
- static? (
- app-arch/bzip2[static-libs]
- app-arch/xz-utils[static-libs]
- sys-libs/libcap[static-libs]
- sys-libs/zlib[static-libs]
- curl? ( net-misc/curl[static-libs] )
- lzo? ( dev-libs/lzo[static-libs] )
- xattr? ( sys-apps/attr[static-libs] )
- )
+ curl? ( net-misc/curl )
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ gpg? ( app-crypt/gpgme )
+ lzo? ( dev-libs/lzo:= )
+ rsync? ( net-libs/librsync:= )
+ xattr? ( sys-apps/attr:= )
"
+
+DEPEND="${RDEPEND}"
+
BDEPEND="
+ doc? ( app-doc/doxygen )
nls? (
sys-devel/gettext
virtual/libintl
)
- doc? ( app-doc/doxygen )
"
REQUIRED_USE="?? ( dar32 dar64 )
gpg? ( gcrypt )"
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
src_configure() {
# configure.ac is totally funked up regarding the AC_ARG_ENABLE
# logic.
@@ -61,7 +52,9 @@ src_configure() {
# Do _not_ use $(use_enable) until you have verified that the
# logic has been fixed by upstream.
local myconf=(
+ --disable-dar-static
--disable-python-binding
+ --disable-static
--disable-upx
$(usex curl '' --disable-libcurl-linking)
$(usex dar32 --enable-mode=32 '')
@@ -79,27 +72,15 @@ src_configure() {
# Bug 103741
filter-flags -fomit-frame-pointer
- if ! use static ; then
- myconf+=( --disable-dar-static )
- if ! use static-libs ; then
- myconf+=( --disable-static )
- fi
- fi
-
econf "${myconf[@]}"
}
src_install() {
emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
- local DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
einstalldocs
- find "${ED}" -name '*.la' -delete || die
-
- if ! use static-libs ; then
- find "${ED}" -name '*.a' -delete || die
- fi
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
# Bug 729150
rm "${ED}/usr/share/doc/${PF}/html/samples/MyBackup.sh.tar.gz" || die