summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-11 02:24:03 +0000
committerSam James <sam@gentoo.org>2021-02-11 02:24:03 +0000
commitef2829d1ac400892265dab27dd486e5a8710c740 (patch)
tree3d16e382ea76ba64c6efe2e70653cbd9b0437bda /app-backup
parentapp-admin/sysrqd: cleanup old (diff)
downloadgentoo-ef2829d1ac400892265dab27dd486e5a8710c740.tar.gz
gentoo-ef2829d1ac400892265dab27dd486e5a8710c740.tar.bz2
gentoo-ef2829d1ac400892265dab27dd486e5a8710c740.zip
app-backup/dar: bump to 2.6.13
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/dar/Manifest1
-rw-r--r--app-backup/dar/dar-2.6.13.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/app-backup/dar/Manifest b/app-backup/dar/Manifest
index af1161313c2c..06d961225b22 100644
--- a/app-backup/dar/Manifest
+++ b/app-backup/dar/Manifest
@@ -1,2 +1,3 @@
DIST dar-2.5.11.tar.gz 1891928 BLAKE2B 536cccca2533f7ddbc8b95972fe00e9c87a404481e6afbd7aa3634c00598403c18950eb876aefe71a818c3bf4df75bff5f3904dc69bd1d75880f6c8a349911a5 SHA512 36b90218a34ac7f41ce9ca0a2167cfb2fd243b23b8e84350153e8804f0faabf87291b4e4b061533bcb0ca079f087c074eeaa12a54ee8084dd386a072ac503847
DIST dar-2.6.10.tar.gz 2140424 BLAKE2B 840a7a3d33825658be541157468a15bc3a3082083a35c426ecbab1cd2e8026e0a4d15671a33472068e1256878d1f60d414c2c069a3223ab5050756b13c887b69 SHA512 2fceafba6c6851c5dd11c0d1a3fda8aeddac16f39cf0051027b178703a5e821fb769c42624063d8722d80ea62bb735f3b0c6c39538c1c939234df49d6b757428
+DIST dar-2.6.13.tar.gz 2148732 BLAKE2B 51de01793dead832209671569f8054b1de3b5fa810c786ae675207b6dc3e639a5c036896e1688e017b222fbaa6c011494a9d43b3bb2b16570a38e291f893b73f SHA512 f0f853db6e15f5abfabf87be06a1c374662c7fa7e1140eaaeef3e8c8c4d0049a00a8e74409d6805ea3ae5b2f3171f2eba27459e8acb4438c467c4f0bd0825c0c
diff --git a/app-backup/dar/dar-2.6.13.ebuild b/app-backup/dar/dar-2.6.13.ebuild
new file mode 100644
index 000000000000..4924de9b8a32
--- /dev/null
+++ b/app-backup/dar/dar-2.6.13.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE="curl dar32 dar64 doc gcrypt gpg lzo nls static static-libs xattr"
+
+RESTRICT="test" # need to be run as root
+
+RDEPEND="
+ >=sys-libs/zlib-1.2.3:=
+ !static? (
+ app-arch/bzip2:=
+ app-arch/xz-utils:=
+ sys-libs/libcap
+ curl? ( net-misc/curl )
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ gpg? ( app-crypt/gpgme )
+ lzo? ( dev-libs/lzo:= )
+ xattr? ( sys-apps/attr:= )
+ )"
+
+DEPEND="
+ ${RDEPEND}
+ static? (
+ app-arch/bzip2[static-libs]
+ app-arch/xz-utils[static-libs]
+ sys-libs/libcap[static-libs]
+ sys-libs/zlib[static-libs]
+ curl? ( net-misc/curl[static-libs] )
+ lzo? ( dev-libs/lzo[static-libs] )
+ xattr? ( sys-apps/attr[static-libs] )
+ )
+"
+BDEPEND="
+ nls? (
+ sys-devel/gettext
+ virtual/libintl
+ )
+ doc? ( app-doc/doxygen )
+"
+
+REQUIRED_USE="?? ( dar32 dar64 )
+ gpg? ( gcrypt )"
+
+src_configure() {
+ # configure.ac is totally funked up regarding the AC_ARG_ENABLE
+ # logic.
+ # For example "--enable-dar-static" causes configure to DISABLE
+ # static builds of dar.
+ # Do _not_ use $(use_enable) until you have verified that the
+ # logic has been fixed by upstream.
+ local myconf=(
+ --disable-python-binding
+ --disable-upx
+ $(usex curl '' --disable-libcurl-linking)
+ $(usex dar32 --enable-mode=32 '')
+ $(usex dar64 --enable-mode=64 '')
+ $(usex doc '' --disable-build-html)
+ #$(usex examples --enable-examples '')
+ $(usex gcrypt '' --disable-libgcrypt-linking)
+ $(usex gpg '' --disable-gpgme-linking)
+ $(usex lzo '' --disable-liblzo2-linking)
+ $(usex nls '' --disable-nls)
+ #$(usex rsync '' --disable-librsync-linking)
+ $(usex xattr '' --disable-ea-support)
+ )
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ if ! use static ; then
+ myconf+=( --disable-dar-static )
+ if ! use static-libs ; then
+ myconf+=( --disable-static )
+ fi
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
+
+ local DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.a' -delete || die
+ fi
+}