summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/acovea-gtk/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/acovea-gtk/files')
-rw-r--r--app-benchmarks/acovea-gtk/files/acovea-gtk-1.0.1-gcc4.3.patch23
-rw-r--r--app-benchmarks/acovea-gtk/files/acovea-gtk-1.0.1-libbrahe.patch8
-rw-r--r--app-benchmarks/acovea-gtk/files/acovea-gtk-1.0.1-libsigc.patch101
-rw-r--r--app-benchmarks/acovea-gtk/files/acovea-gtk-1.0.1-unicode.patch12
4 files changed, 144 insertions, 0 deletions
diff --git a/app-benchmarks/acovea-gtk/files/acovea-gtk-1.0.1-gcc4.3.patch b/app-benchmarks/acovea-gtk/files/acovea-gtk-1.0.1-gcc4.3.patch
new file mode 100644
index 000000000000..30bfc96ab3fa
--- /dev/null
+++ b/app-benchmarks/acovea-gtk/files/acovea-gtk-1.0.1-gcc4.3.patch
@@ -0,0 +1,23 @@
+--- a/src/settings_window.cc
++++ b/src/settings_window.cc
+@@ -6,6 +6,7 @@
+ // This file is for your program, I won't touch it again!
+
+ #include <gtkmm.h>
++#include <cstring>
+ #include "config.h"
+ #include "settings_window.hh"
+
+
+--- a/src/main_window.cc
++++ b/src/main_window.cc
+@@ -9,6 +9,8 @@
+ #include <gtkmm.h>
+ #include <gtkmm/main.h>
+ #include <iomanip>
++#include <cstring>
++#include <sys/stat.h>
+ #include "config.h"
+ #include "main_window.hh"
+
+
diff --git a/app-benchmarks/acovea-gtk/files/acovea-gtk-1.0.1-libbrahe.patch b/app-benchmarks/acovea-gtk/files/acovea-gtk-1.0.1-libbrahe.patch
new file mode 100644
index 000000000000..4511f23e92f5
--- /dev/null
+++ b/app-benchmarks/acovea-gtk/files/acovea-gtk-1.0.1-libbrahe.patch
@@ -0,0 +1,8 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -22,4 +22,4 @@
+ AM_CXXFLAGS = @GTKMM_CFLAGS@
+
+ acovea_gtk_LDFLAGS = -pthread -L//usr/lib
+-acovea_gtk_LDADD = @LIBS@ @GTKMM_LIBS@ -lgthread-2.0 -lglib-2.0 -lcoyotl -levocosm -lacovea -lexpat
++acovea_gtk_LDADD = @LIBS@ @GTKMM_LIBS@ -lgthread-2.0 -lglib-2.0 -lcoyotl -levocosm -lbrahe -lacovea -lexpat
diff --git a/app-benchmarks/acovea-gtk/files/acovea-gtk-1.0.1-libsigc.patch b/app-benchmarks/acovea-gtk/files/acovea-gtk-1.0.1-libsigc.patch
new file mode 100644
index 000000000000..aa60489ae630
--- /dev/null
+++ b/app-benchmarks/acovea-gtk/files/acovea-gtk-1.0.1-libsigc.patch
@@ -0,0 +1,101 @@
+--- a/src/about_box_glade.cc
++++ b/src/about_box_glade.cc
+@@ -1530,8 +1530,8 @@
+ hbuttonbox1->show();
+ vbox3->show();
+ about_box->show();
+- about_close_button->signal_clicked().connect(SigC::slot(*this, &about_box_glade::on_about_close_button_clicked), false);
+- about_box->signal_realize().connect(SigC::slot(*this, &about_box_glade::on_about_box_realize), false);
++ about_close_button->signal_clicked().connect(sigc::mem_fun(*this, &about_box_glade::on_about_close_button_clicked), false);
++ about_box->signal_realize().connect(sigc::mem_fun(*this, &about_box_glade::on_about_box_realize), false);
+ }
+
+ about_box_glade::~about_box_glade()
+--- a/src/main_window_glade.cc
++++ b/src/main_window_glade.cc
+@@ -998,19 +998,19 @@
+ main_status->show();
+ vbox1->show();
+ main_window->show();
+- menu_set_run_options->signal_activate().connect(SigC::slot(*this, &main_window_glade::on_menu_set_run_options_activate), false);
+- menu_save_options_default->signal_activate().connect(SigC::slot(*this, &main_window_glade::on_menu_save_options_default_activate), false);
+- menu_load_default_options->signal_activate().connect(SigC::slot(*this, &main_window_glade::on_menu_load_default_options_activate), false);
+- menu_save_options->signal_activate().connect(SigC::slot(*this, &main_window_glade::on_menu_save_options_activate), false);
+- save_load_options->signal_activate().connect(SigC::slot(*this, &main_window_glade::on_load_options_activate), false);
+- menu_quit->signal_activate().connect(SigC::slot(*this, &main_window_glade::on_menu_quit_activate), false);
+- menu_run->signal_activate().connect(SigC::slot(*this, &main_window_glade::on_menu_run_activate), false);
+- menu_stop->signal_activate().connect(SigC::slot(*this, &main_window_glade::on_menu_stop_activate), false);
+- menu_save_output->signal_activate().connect(SigC::slot(*this, &main_window_glade::on_menu_save_output_activate), false);
+- menu_about->signal_activate().connect(SigC::slot(*this, &main_window_glade::on_about1_activate), false);
+- toolbar_settings_button->signal_clicked().connect(SigC::slot(*this, &main_window_glade::on_toolbar_settings_button_clicked), false);
+- toolbar_run_button->signal_clicked().connect(SigC::slot(*this, &main_window_glade::on_toolbar_run_button_clicked), false);
+- toolbar_stop_button->signal_clicked().connect(SigC::slot(*this, &main_window_glade::on_toolbar_stop_button_clicked), false);
++ menu_set_run_options->signal_activate().connect(sigc::mem_fun(*this, &main_window_glade::on_menu_set_run_options_activate), false);
++ menu_save_options_default->signal_activate().connect(sigc::mem_fun(*this, &main_window_glade::on_menu_save_options_default_activate), false);
++ menu_load_default_options->signal_activate().connect(sigc::mem_fun(*this, &main_window_glade::on_menu_load_default_options_activate), false);
++ menu_save_options->signal_activate().connect(sigc::mem_fun(*this, &main_window_glade::on_menu_save_options_activate), false);
++ save_load_options->signal_activate().connect(sigc::mem_fun(*this, &main_window_glade::on_load_options_activate), false);
++ menu_quit->signal_activate().connect(sigc::mem_fun(*this, &main_window_glade::on_menu_quit_activate), false);
++ menu_run->signal_activate().connect(sigc::mem_fun(*this, &main_window_glade::on_menu_run_activate), false);
++ menu_stop->signal_activate().connect(sigc::mem_fun(*this, &main_window_glade::on_menu_stop_activate), false);
++ menu_save_output->signal_activate().connect(sigc::mem_fun(*this, &main_window_glade::on_menu_save_output_activate), false);
++ menu_about->signal_activate().connect(sigc::mem_fun(*this, &main_window_glade::on_about1_activate), false);
++ toolbar_settings_button->signal_clicked().connect(sigc::mem_fun(*this, &main_window_glade::on_toolbar_settings_button_clicked), false);
++ toolbar_run_button->signal_clicked().connect(sigc::mem_fun(*this, &main_window_glade::on_toolbar_run_button_clicked), false);
++ toolbar_stop_button->signal_clicked().connect(sigc::mem_fun(*this, &main_window_glade::on_toolbar_stop_button_clicked), false);
+ }
+
+ main_window_glade::~main_window_glade()
+--- a/src/settings_window_glade.cc
++++ b/src/settings_window_glade.cc
+@@ -391,11 +391,11 @@
+ hbuttonbox3->show();
+ vbox6->show();
+ settings_window->show();
+- settings_benchmark_browse_button->signal_clicked().connect(SigC::slot(*this, &settings_window_glade::on_settings_benchmark_browse_button_clicked), false);
+- settings_config_browse_button->signal_clicked().connect(SigC::slot(*this, &settings_window_glade::on_settings_config_browse_button_clicked), false);
+- settings_seed_check->signal_toggled().connect(SigC::slot(*this, &settings_window_glade::on_settings_seed_check_toggled), false);
+- settings_cancel_button->signal_clicked().connect(SigC::slot(*this, &settings_window_glade::on_settings_cancel_button_clicked), false);
+- settings_okay_button->signal_clicked().connect(SigC::slot(*this, &settings_window_glade::on_settings_okay_button_clicked), false);
++ settings_benchmark_browse_button->signal_clicked().connect(sigc::mem_fun(*this, &settings_window_glade::on_settings_benchmark_browse_button_clicked), false);
++ settings_config_browse_button->signal_clicked().connect(sigc::mem_fun(*this, &settings_window_glade::on_settings_config_browse_button_clicked), false);
++ settings_seed_check->signal_toggled().connect(sigc::mem_fun(*this, &settings_window_glade::on_settings_seed_check_toggled), false);
++ settings_cancel_button->signal_clicked().connect(sigc::mem_fun(*this, &settings_window_glade::on_settings_cancel_button_clicked), false);
++ settings_okay_button->signal_clicked().connect(sigc::mem_fun(*this, &settings_window_glade::on_settings_okay_button_clicked), false);
+ }
+
+ settings_window_glade::~settings_window_glade()
+--- a/src/about_box_glade.cc
++++ b/src/about_box_glade.cc
+@@ -14,8 +14,7 @@
+ #endif //
+ #include "config.h"
+ #include <gtkmmconfig.h>
+ #if GTKMM_MAJOR_VERSION==2 && GTKMM_MINOR_VERSION>2
+-#include <sigc++/compatibility.h>
+ #define GMM_GTKMM_22_24(a,b) b
+ #else //gtkmm 2.2
+ #define GMM_GTKMM_22_24(a,b) a
+--- a/src/main_window_glade.cc
++++ b/src/main_window_glade.cc
+@@ -14,8 +14,7 @@
+ #endif //
+ #include "config.h"
+ #include <gtkmmconfig.h>
+ #if GTKMM_MAJOR_VERSION==2 && GTKMM_MINOR_VERSION>2
+-#include <sigc++/compatibility.h>
+ #define GMM_GTKMM_22_24(a,b) b
+ #else //gtkmm 2.2
+ #define GMM_GTKMM_22_24(a,b) a
+--- a/src/settings_window_glade.cc
++++ b/src/settings_window_glade.cc
+@@ -14,8 +14,7 @@
+ #endif //
+ #include "config.h"
+ #include <gtkmmconfig.h>
+ #if GTKMM_MAJOR_VERSION==2 && GTKMM_MINOR_VERSION>2
+-#include <sigc++/compatibility.h>
+ #define GMM_GTKMM_22_24(a,b) b
+ #else //gtkmm 2.2
+ #define GMM_GTKMM_22_24(a,b) a
+
diff --git a/app-benchmarks/acovea-gtk/files/acovea-gtk-1.0.1-unicode.patch b/app-benchmarks/acovea-gtk/files/acovea-gtk-1.0.1-unicode.patch
new file mode 100644
index 000000000000..a81d90282f38
--- /dev/null
+++ b/app-benchmarks/acovea-gtk/files/acovea-gtk-1.0.1-unicode.patch
@@ -0,0 +1,12 @@
+--- a/src/main_window.cc
++++ b/src/main_window.cc
+@@ -488,7 +488,7 @@
+ {
+ Glib::RefPtr<Gtk::TextBuffer> buffer = main_window_output->get_buffer();
+ Gtk::TextIter end = buffer->end();
+- buffer->insert(buffer->end(),text->c_str());
++ buffer->insert(buffer->end(),Glib::convert (text->c_str(), "UTF-8", "ISO-8859-1"));
+ }
+
+ void main_window::set_ui_running(bool running)
+