summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Dawson <matthew@mjdsystems.ca>2016-10-17 00:58:25 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2016-10-18 11:57:53 -0400
commitb161b8526becac4105b8b060226c7118d4d5dc92 (patch)
treecc09de3f5af38a21038153b9a1811527d4a0b04f /app-benchmarks/bonnie++/bonnie++-1.97.2.ebuild
parentnet-misc/quagga: revision bump (diff)
downloadgentoo-b161b8526becac4105b8b060226c7118d4d5dc92.tar.gz
gentoo-b161b8526becac4105b8b060226c7118d4d5dc92.tar.bz2
gentoo-b161b8526becac4105b8b060226c7118d4d5dc92.zip
app-benchmarks/bonnie++: Bump to 1.97.2
Fixes gcc 6 compile failures. Package-Manager: portage-2.2.28
Diffstat (limited to 'app-benchmarks/bonnie++/bonnie++-1.97.2.ebuild')
-rw-r--r--app-benchmarks/bonnie++/bonnie++-1.97.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-benchmarks/bonnie++/bonnie++-1.97.2.ebuild b/app-benchmarks/bonnie++/bonnie++-1.97.2.ebuild
new file mode 100644
index 000000000000..14691c20843b
--- /dev/null
+++ b/app-benchmarks/bonnie++/bonnie++-1.97.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+DESCRIPTION="Hard drive bottleneck testing benchmark suite"
+HOMEPAGE="http://www.coker.com.au/bonnie++/"
+SRC_URI="http://www.coker.com.au/bonnie++/experimental/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+S="${WORKDIR}/${P}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.96-compile-flags.patch" #426788
+ "${FILESDIR}"/${PN}-1.97-zcav-array-indexing-fix.patch #309319
+)
+
+DOCS=( README.txt README-2.00 debian/changelog credits.txt )
+HTML_DOCS=( readme.html )
+
+src_configure() {
+ econf \
+ $(usex debug "--enable-debug" "") \
+ --disable-stripping
+}
+
+src_install() {
+ dobin bonnie++ zcav bon_csv2html bon_csv2txt
+ sed -i -e \
+ "s:/usr/share/doc/bonnie++:${EPREFIX}/usr/share/doc/${PF}/html:g" \
+ bonnie++.8 || die #431684
+ doman bon_csv2html.1 bon_csv2txt.1 bonnie++.8 zcav.8
+ einstalldocs
+}