summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-03-24 00:03:26 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-24 09:56:35 +0100
commitb272f01ac9a8cad378882a31b0a442f04c2d015b (patch)
tree9c7b04a0299ca2a0302cc7f6b355f1892d724dbc /app-benchmarks/geekbench/geekbench-2.4.3.ebuild
parentprofiles/license_groups: add geekbench license to EULA group (diff)
downloadgentoo-b272f01ac9a8cad378882a31b0a442f04c2d015b.tar.gz
gentoo-b272f01ac9a8cad378882a31b0a442f04c2d015b.tar.bz2
gentoo-b272f01ac9a8cad378882a31b0a442f04c2d015b.zip
app-benchmarks/geekbench: New package
Closes: https://bugs.gentoo.org/524652 Closes: https://github.com/gentoo/gentoo/pull/7249
Diffstat (limited to 'app-benchmarks/geekbench/geekbench-2.4.3.ebuild')
-rw-r--r--app-benchmarks/geekbench/geekbench-2.4.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-benchmarks/geekbench/geekbench-2.4.3.ebuild b/app-benchmarks/geekbench/geekbench-2.4.3.ebuild
new file mode 100644
index 000000000000..64c1aa20f247
--- /dev/null
+++ b/app-benchmarks/geekbench/geekbench-2.4.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A Cross-Platform Benchmark for Android, iOS, Linux, MacOS and Windows"
+HOMEPAGE="https://www.geekbench.com"
+SRC_URI="https://cdn.primatelabs.com/Geekbench-${PV}-Linux.tar.gz"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="geekbench"
+SLOT="2"
+
+RDEPEND="sys-devel/gcc
+ sys-libs/glibc"
+
+RESTRICT="bindist fetch mirror strip"
+
+S="${WORKDIR}/dist/Geekbench-${PV}-Linux"
+
+QA_PREBUILT="opt/geekbench2/geekbench opt/geekbench2/geekbench_x86_32 opt/geekbench2/geekbench_x86_64"
+
+pkg_nofetch() {
+ elog "Please download ${A} from ${HOMEPAGE}/${PN}2/download/linux"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_install() {
+ exeinto "/opt/geekbench2"
+ doexe "geekbench" "geekbench_x86_32" "geekbench_x86_64"
+
+ insinto "/opt/geekbench2"
+ doins "geekbench.plar"
+
+ dodir "/opt/bin"
+ dosym "../geekbench2/geekbench" "/opt/bin/geekbench2"
+}
+
+pkg_postinst() {
+ elog "If you have purchased a commercial license, you can enter"
+ elog "your email address and your license key with the following command:"
+ elog "geekbench2 -r <email address> <license key>"
+}