summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/gtkperf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/gtkperf')
-rw-r--r--app-benchmarks/gtkperf/Manifest1
-rw-r--r--app-benchmarks/gtkperf/files/gtkperf-0.40-gentoo.patch47
-rw-r--r--app-benchmarks/gtkperf/gtkperf-0.40-r1.ebuild41
-rw-r--r--app-benchmarks/gtkperf/metadata.xml16
4 files changed, 105 insertions, 0 deletions
diff --git a/app-benchmarks/gtkperf/Manifest b/app-benchmarks/gtkperf/Manifest
new file mode 100644
index 000000000000..fa19c21625fb
--- /dev/null
+++ b/app-benchmarks/gtkperf/Manifest
@@ -0,0 +1 @@
+DIST gtkperf_0.40.tar.gz 402982 SHA256 9704344e732038eecbd007dd996a56293a6b027b5b76f3f036273a3fae1ab27b SHA512 d406955b38c0450c3c6a6a7e9fb1fa7b326932325360353001cab6be63c8deaaea487123512740b57cdc28579ee84aabce789df5ce7dfaa92f8d9010f0a6d7be WHIRLPOOL efecc92235b827301bea813478338ff80514e332ba5df889090d4b93dc022618695bba23e13621dddaecf04ff0140d17c9396a75e489667f3339c5f63960318f
diff --git a/app-benchmarks/gtkperf/files/gtkperf-0.40-gentoo.patch b/app-benchmarks/gtkperf/files/gtkperf-0.40-gentoo.patch
new file mode 100644
index 000000000000..eee7faf43b61
--- /dev/null
+++ b/app-benchmarks/gtkperf/files/gtkperf-0.40-gentoo.patch
@@ -0,0 +1,47 @@
+--- gtkperf-0.40/work/gtkperf/configure.in
++++ gtkperf-0.40/work/gtkperf/configure.in
+@@ -8,7 +8,6 @@
+ AM_CONFIG_HEADER(config.h)
+
+ AC_ISC_POSIX
+-CFLAGS=""
+ AC_SUBST(CFLAGS)
+ AC_PROG_CC
+ AM_PROG_CC_STDC
+--- gtkperf-0.40/work/gtkperf/src/timing.c
++++ gtkperf-0.40/work/gtkperf/src/timing.c
+@@ -97,7 +97,7 @@
+ gtk_text_buffer_insert (appdata->textview_info_buffer, &iter,
+ timestring, -1);
+
+- g_printf (timestring);
++ g_printf ("%s", timestring);
+
+ }
+
+@@ -129,7 +129,7 @@
+ gtk_statusbar_push (GTK_STATUSBAR (appdata->statusbar_main), 0,
+ " Test Finished");
+
+- g_printf (timestring);
++ g_printf ("%s", timestring);
+
+ }
+
+@@ -154,5 +154,5 @@
+ gtk_statusbar_push (GTK_STATUSBAR (appdata->statusbar_main), 0,
+ " Running tests...");
+
+- g_printf (timestring);
++ g_printf ("%s", timestring);
+ }
+--- gtkperf-0.40/work/gtkperf/src/main.c
++++ gtkperf-0.40/work/gtkperf/src/main.c
+@@ -5,6 +5,7 @@
+ #endif
+
+ #include <gtk/gtk.h>
++#include <stdlib.h>
+
+ #ifdef HILDONIZED
+ #include <libosso.h>
diff --git a/app-benchmarks/gtkperf/gtkperf-0.40-r1.ebuild b/app-benchmarks/gtkperf/gtkperf-0.40-r1.ebuild
new file mode 100644
index 000000000000..c8b402b2e259
--- /dev/null
+++ b/app-benchmarks/gtkperf/gtkperf-0.40-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="Application designed to test GTK+ performance"
+HOMEPAGE="http://gtkperf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ make_desktop_entry ${PN} ${PN} duck
+
+ rm -rf "${D}/usr/doc" || die
+ dodoc AUTHORS ChangeLog README TODO
+}
diff --git a/app-benchmarks/gtkperf/metadata.xml b/app-benchmarks/gtkperf/metadata.xml
new file mode 100644
index 000000000000..3f97da1d9531
--- /dev/null
+++ b/app-benchmarks/gtkperf/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ GtkPerf is an application designed to test GTK+ performance. The point
+ is to create common testing platform to run predefined GTK+ widgets
+ (opening comboboxes, toggling buttons, scrolling text yms.) and this
+ way define the speed of device/platform.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">gtkperf</remote-id>
+ </upstream>
+</pkgmetadata>