summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-11-16 23:03:58 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-11-16 23:03:58 +0100
commita5aca55815bd5692e581311599f68a6f0aa972d6 (patch)
tree25497180d354fcfd3fb753e507db1e00b2424c75 /app-benchmarks/stress-ng
parentx86/package.use.mask: mask apparmor for app-benchmarks/stress-ng (diff)
downloadgentoo-a5aca55815bd5692e581311599f68a6f0aa972d6.tar.gz
gentoo-a5aca55815bd5692e581311599f68a6f0aa972d6.tar.bz2
gentoo-a5aca55815bd5692e581311599f68a6f0aa972d6.zip
app-benchmarks/stress-ng: fix automagic
Closes: https://bugs.gentoo.org/824050 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-benchmarks/stress-ng')
-rw-r--r--app-benchmarks/stress-ng/metadata.xml3
-rw-r--r--app-benchmarks/stress-ng/stress-ng-0.13.06-r1.ebuild55
2 files changed, 58 insertions, 0 deletions
diff --git a/app-benchmarks/stress-ng/metadata.xml b/app-benchmarks/stress-ng/metadata.xml
index cf330e398b38..70cc32340938 100644
--- a/app-benchmarks/stress-ng/metadata.xml
+++ b/app-benchmarks/stress-ng/metadata.xml
@@ -13,6 +13,9 @@
that exercise floating point, integer, bit manipulation and control flow
and over 20 virtual memory stress tests.
</longdescription>
+ <use>
+ <flag name="apparmor">Add support for AppArmor.</flag>
+ </use>
<upstream>
<bugs-to>https://github.com/ColinIanKing/stress-ng/issues</bugs-to>
<remote-id type="github">ColinIanKing/stress-ng</remote-id>
diff --git a/app-benchmarks/stress-ng/stress-ng-0.13.06-r1.ebuild b/app-benchmarks/stress-ng/stress-ng-0.13.06-r1.ebuild
new file mode 100644
index 000000000000..108507d2ca81
--- /dev/null
+++ b/app-benchmarks/stress-ng/stress-ng-0.13.06-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="Stress test for a computer system with various selectable ways"
+HOMEPAGE="https://github.com/ColinIanKing/stress-ng"
+SRC_URI="https://github.com/ColinIanKing/${PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="apparmor sctp"
+
+DEPEND="
+ dev-libs/libaio
+ dev-libs/libbsd
+ dev-libs/libgcrypt:0=
+ sys-apps/attr
+ sys-apps/keyutils:=
+ sys-libs/libcap
+ sys-libs/zlib
+ virtual/libcrypt:=
+ apparmor? (
+ sys-apps/apparmor-utils
+ sys-libs/libapparmor
+ )
+ sctp? ( net-misc/lksctp-tools )
+"
+
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.md" "README.Android" "TODO" "syscalls.txt" )
+
+pkg_pretend() {
+ if use apparmor; then
+ CONFIG_CHECK="SECURITY_APPARMOR"
+ check_extra_config
+ fi
+}
+
+src_compile() {
+ tc-export CC
+
+ local myemakeopts=(
+ HAVE_APPARMOR="$(usex apparmor 1 0)"
+ HAVE_LIB_SCTP="$(usex sctp 1 0)"
+ MAN_COMPRESS="0"
+ VERBOSE="1"
+ )
+
+ emake "${myemakeopts[@]}"
+}