summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-09-21 22:28:03 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-09-23 20:08:50 +0300
commit0e8d3369b3a3ab67f484bd1595a014eb9ded7d1a (patch)
tree2a9c3ac19c6cbad0bc9d6cffa133c35c5297b98f /app-benchmarks
parentnet-misc/ipmiview: bump to version 2.16.0 (diff)
downloadgentoo-0e8d3369b3a3ab67f484bd1595a014eb9ded7d1a.tar.gz
gentoo-0e8d3369b3a3ab67f484bd1595a014eb9ded7d1a.tar.bz2
gentoo-0e8d3369b3a3ab67f484bd1595a014eb9ded7d1a.zip
app-benchmarks/stress-ng: bump to version 0.10.05
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/stress-ng/Manifest1
-rw-r--r--app-benchmarks/stress-ng/stress-ng-0.10.05.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-benchmarks/stress-ng/Manifest b/app-benchmarks/stress-ng/Manifest
index a57673ef5194..434c18977000 100644
--- a/app-benchmarks/stress-ng/Manifest
+++ b/app-benchmarks/stress-ng/Manifest
@@ -1 +1,2 @@
DIST stress-ng-0.10.04.tar.xz 401148 BLAKE2B c5c1db3e5fc7316b5620311934f0119d00193f8d73d6705ff6597affebd78e81f3132a9748adc8beb7437261162c835346566a32501205416d223b9d03629423 SHA512 44097bd5a26b7c84ea69b47fc23be3a43369ad8325af375cfc51e45e51d8caabb84ea1af25aff00f042cc564980d7b3fc4b997cfb6246ab562a2f6e11d94ee5e
+DIST stress-ng-0.10.05.tar.xz 401176 BLAKE2B f9562656b361e9a931f4ed65e57865310ac6b1630e48c1fd3680f5d5aeb644ac59f1b4f57760faebe6604cfa1f3619530aeef883f34bd573594767095e6d1201 SHA512 b6ea5d9b20431297988861c4416250960c340050a2e1958f93459b3bbfd4c801c61463efdf5a190d33b76627db05fe8288ebbb3aa12f48734dc93d36266bf363
diff --git a/app-benchmarks/stress-ng/stress-ng-0.10.05.ebuild b/app-benchmarks/stress-ng/stress-ng-0.10.05.ebuild
new file mode 100644
index 000000000000..b2c3a4b18a19
--- /dev/null
+++ b/app-benchmarks/stress-ng/stress-ng-0.10.05.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Stress test for a computer system with various selectable ways"
+HOMEPAGE="https://kernel.ubuntu.com/~cking/stress-ng/"
+SRC_URI="https://kernel.ubuntu.com/~cking/tarballs/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/libaio
+ dev-libs/libbsd
+ dev-libs/libgcrypt:0=
+ net-misc/lksctp-tools
+ sys-apps/attr
+ sys-apps/keyutils:=
+ sys-libs/libapparmor
+ sys-libs/libcap
+ sys-libs/zlib:=
+"
+
+RDEPEND="${DEPEND}"
+
+DOCS=( "README" "README.Android" "TODO" "syscalls.txt" )
+
+PATCHES=( "${FILESDIR}/${PN}-0.09.53-makefile.patch" )
+
+src_compile() {
+ tc-export CC
+
+ default
+}