summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-09-08 15:52:46 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-10-20 09:57:22 +0300
commit390b6e304492abc975895a83359042db7beaeb22 (patch)
tree2f757ee1753ce37eb2d33828aea3eecfd7cd4b0e /app-benchmarks
parentnet-im/zoom: add 5.16.2.8828 (diff)
downloadgentoo-390b6e304492abc975895a83359042db7beaeb22.tar.gz
gentoo-390b6e304492abc975895a83359042db7beaeb22.tar.bz2
gentoo-390b6e304492abc975895a83359042db7beaeb22.zip
app-benchmarks/siege: Fix incompatible pointer to integer conversion
Closes: https://bugs.gentoo.org/894338 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32690 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/siege/files/siege-4.1.6-clang16-build-fix.patch32
-rw-r--r--app-benchmarks/siege/siege-4.1.6-r1.ebuild55
2 files changed, 87 insertions, 0 deletions
diff --git a/app-benchmarks/siege/files/siege-4.1.6-clang16-build-fix.patch b/app-benchmarks/siege/files/siege-4.1.6-clang16-build-fix.patch
new file mode 100644
index 000000000000..1d36fdfd22d8
--- /dev/null
+++ b/app-benchmarks/siege/files/siege-4.1.6-clang16-build-fix.patch
@@ -0,0 +1,32 @@
+Bug: https://bugs.gentoo.org/894338
+--- a/src/cookies.c
++++ b/src/cookies.c
+@@ -66,7 +66,7 @@ cookies_destroy(COOKIES this)
+ BOOLEAN
+ cookies_add(COOKIES this, char *str, char *host)
+ {
+- size_t id = pthread_self();
++ size_t id = (size_t) pthread_self();
+ //int hlen = 0;
+ //int dlen = 0;
+ NODE *cur = NULL;
+@@ -169,7 +169,7 @@ cookies_header(COOKIES this, char *host, char *newton)
+ time_t now;
+ struct tm tm;
+ char oreo[MAX_COOKIES_SIZE];
+- size_t id = pthread_self();
++ size_t id = (size_t) pthread_self();
+
+ memset(oreo, '\0', sizeof oreo);
+
+--- a/src/ftp.c
++++ b/src/ftp.c
+@@ -151,7 +151,7 @@ ftp_stor(CONN *C, URL U)
+ {
+ size_t len;
+ char *file;
+- size_t id = pthread_self();
++ size_t id = (size_t) pthread_self();
+ int num = 2;
+ char **parts;
+
diff --git a/app-benchmarks/siege/siege-4.1.6-r1.ebuild b/app-benchmarks/siege/siege-4.1.6-r1.ebuild
new file mode 100644
index 000000000000..5b1dafa81d01
--- /dev/null
+++ b/app-benchmarks/siege/siege-4.1.6-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools bash-completion-r1
+
+DESCRIPTION="A HTTP regression testing and benchmarking utility"
+HOMEPAGE="https://www.joedog.org/siege-home https://github.com/JoeDog/siege"
+SRC_URI="http://download.joedog.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~x86 ~x64-macos"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ ssl? ( dev-libs/openssl:0= )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.1.6-clang16-build-fix.patch
+)
+
+src_prepare() {
+ default
+ # bundled macros break recent libtool
+ # remove /usr/lib from LDFLAGS, bug #732886
+ sed -i \
+ -e '/AC_PROG_SHELL/d' \
+ -e 's/SSL_LDFLAGS="-L.*lib"/SSL_LDFLAGS=""/g' \
+ -e 's/Z_LDFLAGS="-L.*lib"/Z_LDFLAGS=""/g' \
+ configure.ac || die "Failed to sed configure.ac"
+ rm *.m4 || die "failed to remove bundled macros"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=( $(use_with ssl ssl "${EPREFIX}/usr") )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ dodoc AUTHORS ChangeLog INSTALL README* doc/siegerc doc/urls.txt
+
+ newbashcomp "${FILESDIR}/${PN}".bash-completion "${PN}"
+}
+
+pkg_postinst() {
+ elog "An example ~/.siegerc file has been installed in"
+ elog "${EPREFIX}/usr/share/doc/${PF}/"
+}