summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-03 04:18:43 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-03 04:18:43 -0400
commit60539d5e9005303c0c453f47d18682d261f910bd (patch)
tree6d8df0bfdb6cbe0cf62c61a47eab52f530a3c54a /app-benchmarks
parentnet-libs/libwebsockets: bump to 2.0.2 (diff)
downloadgentoo-60539d5e9005303c0c453f47d18682d261f910bd.tar.gz
gentoo-60539d5e9005303c0c453f47d18682d261f910bd.tar.bz2
gentoo-60539d5e9005303c0c453f47d18682d261f910bd.zip
app-benchmarks/httperf: add libressl support
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/httperf/httperf-0.9.0-r3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-benchmarks/httperf/httperf-0.9.0-r3.ebuild b/app-benchmarks/httperf/httperf-0.9.0-r3.ebuild
new file mode 100644
index 000000000000..23cfdcc29825
--- /dev/null
+++ b/app-benchmarks/httperf/httperf-0.9.0-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils toolchain-funcs
+
+DESCRIPTION="A tool from HP for measuring web server performance"
+HOMEPAGE="https://github.com/httperf/httperf"
+SRC_URI="https://httperf.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~amd64-linux ~x64-macos"
+IUSE="debug libressl"
+
+RDEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_configure() {
+ econf --bindir="${EPREFIX}"/usr/bin \
+ $(use_enable debug)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" -j1
+}