summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcapezotte <carana2099@gmail.com>2022-01-26 11:13:46 -0300
committerFlorian Schmaus <flow@gentoo.org>2022-01-28 11:45:45 +0100
commit8e37caa8b775fb233fdfb540f605bec6dc7b7534 (patch)
tree7abe7b6119bf3c6fecfb9f63c31bf648617ff865 /app-benchmarks
parentwww-client/microsoft-edge-dev: add USE=mip (diff)
downloadgentoo-8e37caa8b775fb233fdfb540f605bec6dc7b7534.tar.gz
gentoo-8e37caa8b775fb233fdfb540f605bec6dc7b7534.tar.bz2
gentoo-8e37caa8b775fb233fdfb540f605bec6dc7b7534.zip
app-benchmarks/bootchart2: bump to 0.14.9
Signed-off-by: capezotte <carana2099@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/23966 Signed-off-by: Florian Schmaus <flow@gentoo.org> Modified-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/bootchart2/Manifest1
-rw-r--r--app-benchmarks/bootchart2/bootchart2-0.14.9.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-benchmarks/bootchart2/Manifest b/app-benchmarks/bootchart2/Manifest
index 34f275c76d38..01604a6ee14f 100644
--- a/app-benchmarks/bootchart2/Manifest
+++ b/app-benchmarks/bootchart2/Manifest
@@ -1 +1,2 @@
DIST bootchart2-0.14.8.tar.gz 1175527 BLAKE2B 623ca2269420eda79b09d955ab9d4a37af004e9e97ad0e0c6014e53b4b0c63239661cb5359345306504980b060ccd11488970cb0aa3d832bfb55392724e715dd SHA512 58303db91d22ccc44c0dc765e7a6672fb277840555fd87ce64b8987cba85250cfe3db17f3ec7e0e1e726ad59166a5d3d01a7a262c07b5690c595877b46c66bd0
+DIST bootchart2-0.14.9.tar.gz 1175710 BLAKE2B af472193c7de313e770da1a88baf00e9ee38e36c0d3c900bab2657bfa5d2398dd9edc616ec770f49a6c5fa8e29f738ddf2c0951ea039a48a2a89b0ffd94759fb SHA512 7ee1220b0add027fc39f710cc01119d7aaa22fe11736497b089c26955216cef10552216ed29ca55bf08aa848f92bb11d74deeb3aa69769dfecf3a55aa988e58b
diff --git a/app-benchmarks/bootchart2/bootchart2-0.14.9.ebuild b/app-benchmarks/bootchart2/bootchart2-0.14.9.ebuild
new file mode 100644
index 000000000000..95f488b32786
--- /dev/null
+++ b/app-benchmarks/bootchart2/bootchart2-0.14.9.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="Performance analysis and visualization of the system boot process"
+HOMEPAGE="https://github.com/xrmx/bootchart"
+SRC_URI="https://github.com/xrmx/bootchart/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+cairo"
+
+RESTRICT="!cairo? ( test )"
+
+RDEPEND="
+ !app-benchmarks/bootchart
+ cairo? ( dev-python/pycairo )
+ sys-apps/lsb-release"
+
+S="${WORKDIR}"/${PN%2}-${PV}
+
+CONFIG_CHECK="~PROC_EVENTS ~TASKSTATS ~TASK_DELAY_ACCT ~TMPFS"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.14.8-no-compressed-man.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+ sed -i \
+ -e "/^SYSTEMD_UNIT_DIR/s:=.*:= $(systemd_get_systemunitdir):g" \
+ Makefile || die
+
+ if ! use cairo; then
+ sed -i \
+ -e "/^install/s:py-install-compile::g" \
+ -e "/pybootchartgui.1/d" \
+ Makefile || die
+ fi
+
+ sed -i \
+ -e '/^EXIT_PROC/s:^.*$:EXIT_PROC="agetty mgetty mingetty:g' \
+ bootchartd.conf bootchartd.in || die
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ export DOCDIR=/usr/share/doc/${PF}
+ default
+
+ # Note: LIBDIR is hardcoded as /lib in collector/common.h, so we shouldn't
+ # just change it. Since no libraries are installed, /lib is fine.
+ keepdir /lib/bootchart/tmpfs
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+}
+
+pkg_postinst() {
+ elog "If you are using an initrd during boot"
+ elog "please add the init script to your default runlevel"
+ if has_version sys-apps/openrc; then
+ elog "rc-update add bootchart2 default"
+ fi
+}