summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-16 02:00:34 +0000
committerSam James <sam@gentoo.org>2020-09-16 02:00:34 +0000
commit9cc464c43d3ebd1c493244b3e5816c65eb0a2aa5 (patch)
tree6e8cfbcd4e4be42f46e809eef9b8dea86addf33b /app-benchmarks
parentapp-benchmarks/siege-4.0.7: version bump (diff)
downloadgentoo-9cc464c43d3ebd1c493244b3e5816c65eb0a2aa5.tar.gz
gentoo-9cc464c43d3ebd1c493244b3e5816c65eb0a2aa5.tar.bz2
gentoo-9cc464c43d3ebd1c493244b3e5816c65eb0a2aa5.zip
app-benchmarks/siege: forward-port LDFLAGS changes
Bug: https://bugs.gentoo.org/732886 Closes: https://github.com/gentoo/gentoo/pull/17356 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/siege/siege-4.0.7.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-benchmarks/siege/siege-4.0.7.ebuild b/app-benchmarks/siege/siege-4.0.7.ebuild
index 96acf64824f7..7309c86336a0 100644
--- a/app-benchmarks/siege/siege-4.0.7.ebuild
+++ b/app-benchmarks/siege/siege-4.0.7.ebuild
@@ -23,7 +23,12 @@ DEPEND="${RDEPEND}"
src_prepare() {
default
# bundled macros break recent libtool
- sed -i -e '/AC_PROG_SHELL/d' configure.ac || die
+ # remove /usr/lib from LDFLAGS, bug #732886
+ sed -i \
+ -e '/AC_PROG_SHELL/d' \
+ -e 's/SSL_LDFLAGS="-L.*lib"/SSL_LDFLAGS=""/g' \
+ -e 's/Z_LDFLAGS="-L.*lib"/Z_LDFLAGS=""/g' \
+ configure.ac || die
rm *.m4 || die "failed to remove bundled macros"
eautoreconf
}
@@ -36,7 +41,7 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install
+ emake DESTDIR="${ED}" install
dodoc AUTHORS ChangeLog INSTALL README* doc/siegerc doc/urls.txt