summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-27 20:28:47 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-27 20:28:57 +0200
commita19b3c5e7acaa10e6eff2d2d16e519cd79a103d5 (patch)
treecea87d468bde26409768737a9dd6bd06ccc20845 /app-benchmarks
parentsys-process/glances: bump to 3.1.5 (diff)
downloadgentoo-a19b3c5e7acaa10e6eff2d2d16e519cd79a103d5.tar.gz
gentoo-a19b3c5e7acaa10e6eff2d2d16e519cd79a103d5.tar.bz2
gentoo-a19b3c5e7acaa10e6eff2d2d16e519cd79a103d5.zip
app-benchmarks/interbench: fix compilation with musl
Closes: https://bugs.gentoo.org/715426 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/interbench/files/interbench-0.31-musl.patch10
-rw-r--r--app-benchmarks/interbench/interbench-0.31.ebuild7
2 files changed, 15 insertions, 2 deletions
diff --git a/app-benchmarks/interbench/files/interbench-0.31-musl.patch b/app-benchmarks/interbench/files/interbench-0.31-musl.patch
new file mode 100644
index 000000000000..df673be5114a
--- /dev/null
+++ b/app-benchmarks/interbench/files/interbench-0.31-musl.patch
@@ -0,0 +1,10 @@
+--- interbench-0.31.orig/interbench.c 2016-10-21 02:28:00.000000000 +0000
++++ interbench-0.31/interbench.c 2020-08-27 16:24:51.521420811 +0000
+@@ -42,6 +42,7 @@
+ #include <sys/utsname.h>
+ #include <sys/time.h>
+ #include <sys/resource.h>
++#include <sys/stat.h>
+ #include <sys/types.h>
+ #include <sys/mman.h>
+ #include <sys/wait.h>
diff --git a/app-benchmarks/interbench/interbench-0.31.ebuild b/app-benchmarks/interbench/interbench-0.31.ebuild
index dfa772bcebbb..b77a5a4b1187 100644
--- a/app-benchmarks/interbench/interbench-0.31.ebuild
+++ b/app-benchmarks/interbench/interbench-0.31.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,10 @@ KEYWORDS="amd64 x86"
LICENSE="GPL-2+"
SLOT="0"
-PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${P}-musl.patch"
+)
DOCS=(
"readme"