summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-07-08 09:48:47 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-07-15 09:03:20 +0300
commitfc17a33eae8f0a14c24b494f45d8c1a4fcade4a7 (patch)
treec33a2bb8f0ce2c146dfe48dfd6808ba2cf9e6bb0 /app-benchmarks
parentdev-libs/libtpms: Bump to 0.8.4 (diff)
downloadgentoo-fc17a33eae8f0a14c24b494f45d8c1a4fcade4a7.tar.gz
gentoo-fc17a33eae8f0a14c24b494f45d8c1a4fcade4a7.tar.bz2
gentoo-fc17a33eae8f0a14c24b494f45d8c1a4fcade4a7.zip
app-benchmarks/siege: bump to 4.1.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Closes: https://github.com/gentoo/gentoo/pull/21562 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/siege/Manifest1
-rw-r--r--app-benchmarks/siege/siege-4.1.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-benchmarks/siege/Manifest b/app-benchmarks/siege/Manifest
index 4315c4ee157c..38d47ae4474d 100644
--- a/app-benchmarks/siege/Manifest
+++ b/app-benchmarks/siege/Manifest
@@ -1 +1,2 @@
DIST siege-4.0.9.tar.gz 525804 BLAKE2B d857df05f40a0ac26a8abdd54e7de374125dde4c114bd1ac3ddd9e9856a30d4fdfefd325980717e59b5876df99a87f971c5b3f91d6478f9638f1860557615169 SHA512 6208b7924162be4dd7ea8cdc297930d28e8a1cb125cf26e8707c2cb67efad741cd090c12081ea80837314d4b5703da152a97b0e8fbf4c64ff64c6714eb4b5fc7
+DIST siege-4.1.0.tar.gz 541331 BLAKE2B c3e8e0f101e27a0902de80478e7c6595f44b4d129cfb265d66c48fcacef4129f587f9ca9ddd0c4d5016513ba19d7635135add1cb02290c4d2bbed5cea501a816 SHA512 15b3b82877153f044524cedc96750a6dab4d21ccbef1be53c0069adade6c3b4204287852a30a57275eea0f51c702857dff59648bd885c28ce65feae141cf6593
diff --git a/app-benchmarks/siege/siege-4.1.0.ebuild b/app-benchmarks/siege/siege-4.1.0.ebuild
new file mode 100644
index 000000000000..c30cdda7f064
--- /dev/null
+++ b/app-benchmarks/siege/siege-4.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1
+
+DESCRIPTION="A HTTP regression testing and benchmarking utility"
+HOMEPAGE="https://www.joedog.org/siege-home https://github.com/JoeDog/siege"
+SRC_URI="http://download.joedog.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~x86 ~x64-macos"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ # bundled macros break recent libtool
+ # remove /usr/lib from LDFLAGS, bug #732886
+ sed -i \
+ -e '/AC_PROG_SHELL/d' \
+ -e 's/SSL_LDFLAGS="-L.*lib"/SSL_LDFLAGS=""/g' \
+ -e 's/Z_LDFLAGS="-L.*lib"/Z_LDFLAGS=""/g' \
+ configure.ac || die
+ rm *.m4 || die "failed to remove bundled macros"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_with ssl ssl "${EPREFIX}/usr")
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ dodoc AUTHORS ChangeLog INSTALL README* doc/siegerc doc/urls.txt
+
+ newbashcomp "${FILESDIR}/${PN}".bash-completion "${PN}"
+}
+
+pkg_postinst() {
+ elog "An example ~/.siegerc file has been installed in"
+ elog "${EPREFIX}/usr/share/doc/${PF}/"
+}