summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/bashburn/bashburn-3.1.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/bashburn/bashburn-3.1.0.ebuild')
-rw-r--r--app-cdr/bashburn/bashburn-3.1.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-cdr/bashburn/bashburn-3.1.0.ebuild b/app-cdr/bashburn/bashburn-3.1.0.ebuild
new file mode 100644
index 000000000000..4e9c800283d7
--- /dev/null
+++ b/app-cdr/bashburn/bashburn-3.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_P=BashBurn-${PV}
+
+DESCRIPTION="A shell script for burning optical media"
+HOMEPAGE="http://bashburn.dose.se/"
+SRC_URI="http://bashburn.dose.se/index.php?s=file_download&id=25 -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 sparc x86"
+IUSE=""
+
+DEPEND="app-shells/bash"
+RDEPEND="${DEPEND}
+ app-cdr/cdrdao
+ app-cdr/dvd+rw-tools
+ media-libs/flac
+ || ( dev-libs/libcdio-paranoia media-sound/cdparanoia )
+ media-sound/lame
+ || ( media-sound/mpg123 media-sound/mpg321 )
+ media-sound/normalize
+ media-sound/vorbis-tools
+ virtual/cdrtools
+ virtual/eject"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Fix for "warning: jobserver unavailable: using -j1."
+ sed -i -e 's:make -C:$(MAKE) -C:' Makefile || die
+}
+
+src_install() {
+ ./Install.sh --prefix="${D}"/usr || die
+
+ # Remove /var/tmp/portage from installed script
+ sed -i \
+ -e "/BBROOTDIR=/s:'.*':'/usr/lib/Bashburn/lib':" \
+ "${ED}"/usr/lib/Bashburn/lib/BashBurn.sh || die
+
+ rm -rf "${ED}"/usr/lib/Bashburn/lib/docs
+ dodoc docs/{ChangeLog,CREDITS,FAQ,HOWTO,README,TODO,TRANSLATION_RULE}
+}