summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2016-02-28 23:46:07 -0500
committerAlexandre Rostovtsev <tetromino@gentoo.org>2016-02-29 00:10:48 -0500
commita59a127613f32237ad8702a047504d32275b8256 (patch)
tree49bc03d164a960003da84212f8544bdf89282215 /app-cdr/cdemu-daemon/cdemu-daemon-3.0.4.ebuild
parentdev-libs/libmirage: bump to 3.0.4 for bug #571034 and eapi6-ify (diff)
downloadgentoo-a59a127613f32237ad8702a047504d32275b8256.tar.gz
gentoo-a59a127613f32237ad8702a047504d32275b8256.tar.bz2
gentoo-a59a127613f32237ad8702a047504d32275b8256.zip
app-cdr/cdemu-daemon: bump to 3.0.4 for bug #571034 and eapi6-ify
Thanks to Rafał Mużyło. Package-Manager: portage-2.2.27
Diffstat (limited to 'app-cdr/cdemu-daemon/cdemu-daemon-3.0.4.ebuild')
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-3.0.4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.0.4.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.0.4.ebuild
new file mode 100644
index 000000000000..07971177cee3
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-3.0.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+CMAKE_MIN_VERSION="2.8.5"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.32:2
+ >=dev-libs/libmirage-${PV}:=
+ >=media-libs/libao-0.8.0:=
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ DOCS="AUTHORS README"
+ cmake-utils_src_prepare
+}
+
+pkg_postinst() {
+ elog "You will need to load the vhba module to use cdemu devices:"
+ elog " # modprobe vhba"
+ elog "To automatically load the vhba module at boot time, edit your"
+ elog "/etc/conf.d/modules file."
+
+ if [[ -e "${ROOT}etc/conf.d/cdemud" ]]; then
+ elog
+ elog "${PN} no longer installs an init.d service; instead, it is"
+ elog "automatically activated when needed via dbus."
+ elog "You can therefore remove ${ROOT}etc/conf.d/cdemud"
+ fi
+}