summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-28 08:52:43 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-28 09:07:49 +0200
commit462aae26f8feb22df96d0a0a1b0f2495bac0954a (patch)
treefaa892154521f25977c97deb983fdc7efed4345e /app-cdr/cdemu
parentapp-cdr/gcdemu: Bump to 3.2.2 (diff)
downloadgentoo-462aae26f8feb22df96d0a0a1b0f2495bac0954a.tar.gz
gentoo-462aae26f8feb22df96d0a0a1b0f2495bac0954a.tar.bz2
gentoo-462aae26f8feb22df96d0a0a1b0f2495bac0954a.zip
app-cdr/cdemu: Bump to 3.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-cdr/cdemu')
-rw-r--r--app-cdr/cdemu/Manifest1
-rw-r--r--app-cdr/cdemu/cdemu-3.2.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-cdr/cdemu/Manifest b/app-cdr/cdemu/Manifest
index b3611e57e207..469a0d6f7b1e 100644
--- a/app-cdr/cdemu/Manifest
+++ b/app-cdr/cdemu/Manifest
@@ -1 +1,2 @@
DIST cdemu-client-3.2.1.tar.bz2 43584 BLAKE2B d34c09203b7b4e70161d62aee48d531b083952174fd2357bf0fc7b69a0fd59200bedb9ca87fe2d2c18c953979c84e9db3fec4d5fb500375f0bcc155dcaf5cedb SHA512 913c26754d16c339d7ddb4e00cc7d5b754ad6cc7f1a156c9448b51ed09468cf9e8a2bc74ed123a621278d2ad281e447d33ee06c3416bc1d0d2e6c2becd539154
+DIST cdemu-client-3.2.2.tar.bz2 44305 BLAKE2B 3a656bfda48a502752cb2b14df413a26467a1512b867cc1519f3dfd21b764a8086135a70b13272f258eb079ce169f58af55665e56238a7ba57cf4e9d84f07751 SHA512 ab5c1b1c741945618581bedb18a6eebdcb55915dc811e4247f0c3afe17729f7fbfaaaec10302e444a2f237c5a1401aa402a614685a84c63442907982e759ff41
diff --git a/app-cdr/cdemu/cdemu-3.2.2.ebuild b/app-cdr/cdemu/cdemu-3.2.2.ebuild
new file mode 100644
index 000000000000..76a0b4986339
--- /dev/null
+++ b/app-cdr/cdemu/cdemu-3.2.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit bash-completion-r1 cmake-utils python-single-r1 xdg-utils
+
+DESCRIPTION="Command-line tool for controlling cdemu-daemon"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/cdemu-client-${PV}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cdemu-daemon"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ cdemu-daemon? ( app-cdr/cdemu-daemon:0/7 )"
+DEPEND="
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.21
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig"
+
+S=${WORKDIR}/cdemu-client-${PV}
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ python_fix_shebang src/cdemu
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPOST_INSTALL_HOOKS=OFF
+ -DCMAKE_INSTALL_COMPLETIONSDIR="$(get_bashcompdir)"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}