summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-28 12:41:14 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-28 13:03:16 +0100
commitbea66b0dfb9f08c92bb43c7f10bfc93db4e6bcf0 (patch)
tree5976f2965760182df7ff6f5c772da571234ab968 /app-cdr/cuegen/cuegen-1.2.0.ebuild
parentapp-cdr/dvdshrink: Port to EAPI 6 (diff)
downloadgentoo-bea66b0dfb9f08c92bb43c7f10bfc93db4e6bcf0.tar.gz
gentoo-bea66b0dfb9f08c92bb43c7f10bfc93db4e6bcf0.tar.bz2
gentoo-bea66b0dfb9f08c92bb43c7f10bfc93db4e6bcf0.zip
app-cdr/cuegen: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-cdr/cuegen/cuegen-1.2.0.ebuild')
-rw-r--r--app-cdr/cuegen/cuegen-1.2.0.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/app-cdr/cuegen/cuegen-1.2.0.ebuild b/app-cdr/cuegen/cuegen-1.2.0.ebuild
index 7fbb0a2d7049..2f72c4191258 100644
--- a/app-cdr/cuegen/cuegen-1.2.0.ebuild
+++ b/app-cdr/cuegen/cuegen-1.2.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
-inherit eutils toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="CUEgen is a FLAC-compatible cuesheet generator for Linux"
HOMEPAGE="http://www.cs.man.ac.uk/~slavinp/cuegen.html"
@@ -14,18 +14,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND=""
+PATCHES=( "${FILESDIR}"/${PN}-1.2.0-fix-build-system.patch )
-src_prepare() {
- sed -i -e 's:\(\${CFLAGS}\):\1 \${LDFLAGS}:g' Makefile
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+src_configure() {
+ append-cflags -W -Wall -Wstrict-prototypes -Wmissing-prototypes
+ tc-export CC
}
src_install() {
- dobin cuegen || die "install failed"
- dodoc README
+ dobin cuegen
+ einstalldocs
}