summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-03 13:06:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-03 17:39:34 +0100
commit6166da0c8497e20d80a511c3c314426c32e5189e (patch)
treecec62ad414e730a6d73fe7b810fbae0a35e84f13 /app-cdr
parentkde-apps/umbrello: 22.08.3 version bump (diff)
downloadgentoo-6166da0c8497e20d80a511c3c314426c32e5189e.tar.gz
gentoo-6166da0c8497e20d80a511c3c314426c32e5189e.tar.bz2
gentoo-6166da0c8497e20d80a511c3c314426c32e5189e.zip
app-cdr/dolphin-plugins-mountiso: 22.08.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest1
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-22.08.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
index bea404c80e65..0807aa4f9ce3 100644
--- a/app-cdr/dolphin-plugins-mountiso/Manifest
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-22.04.3.tar.xz 257356 BLAKE2B e3d084e628920a08c9e1173c754002f6b0ecfad07bd4d89a64f5b29a7e93362a814ead6aeff80412b01e7198adce78c36f36428560a1ea9e555027113f7d8e6f SHA512 1b96511fbf8ec93b03a5f204c2e4cff232ca0d09e4d1599c89d4d514deb3fb889dfd3050a5cabe4e35b6e65a5283ad09635a13931c8484eebc98a22ba9057b42
DIST dolphin-plugins-22.08.2.tar.xz 259816 BLAKE2B 0a7202e1a2397058b34d32976542e58a26602d4791bf2b6e1efcfb4fb5170393c768f7288dcdc00261e80f176c47ead3f299d8f6f2969d9ca36be338b85f7825 SHA512 8636ded42f0bed07cd26986032c111f98e6e5225176d6221cb7691fe4cc5cd29ba2512e741240c64ba7c4bd72cfdb5f21c4762dd45c1493b9f3aefff63936889
+DIST dolphin-plugins-22.08.3.tar.xz 260088 BLAKE2B 2927d42a603776cc3b600606ff2f27a77c8bbbe6b089d3e691571c7594d0e4d53023064afbf07e02f546073823a873fd45f200ea13b9e2765b61046602d8239b SHA512 2201858d9d349c28cced78dcfd9a31c3fde05b3ab107a28615af4cc5c32d4315074881f78dfb255638a13269de16ab68b7c53b68d013cf46ded091f8b059173e
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-22.08.3.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-22.08.3.ebuild
new file mode 100644
index 000000000000..74ecc2e681b7
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-22.08.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=5.96.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}