summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-19 08:19:24 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-19 08:44:52 +0200
commitdecae6db9107313c0bd508c0ba099889aabd802f (patch)
tree384e02cfe0b422887aaa559842d4bbbfdd0c1fcd /app-cdr
parentdev-libs/libmirage: Bump to 3.2.5 (diff)
downloadgentoo-decae6db9107313c0bd508c0ba099889aabd802f.tar.gz
gentoo-decae6db9107313c0bd508c0ba099889aabd802f.tar.bz2
gentoo-decae6db9107313c0bd508c0ba099889aabd802f.zip
app-cdr/cdemu-daemon: Bump to 3.2.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/cdemu-daemon/Manifest1
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-3.2.5.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-cdr/cdemu-daemon/Manifest b/app-cdr/cdemu-daemon/Manifest
index 196d99db88e3..244f5de15741 100644
--- a/app-cdr/cdemu-daemon/Manifest
+++ b/app-cdr/cdemu-daemon/Manifest
@@ -1 +1,2 @@
DIST cdemu-daemon-3.2.4.tar.bz2 83580 BLAKE2B 56cfde3b9b9a98ba0da629deac717a740b7c92c67195ac282af5337f0e782b555f53221741a59abf3e78faacd066e34a722d08e27cef6fd1082cb75b46eb3ace SHA512 b5dd19a9325773e22c1910ae02f351803fb4f02197eaf5d41a984b4898a5fb0f027c70791d4c25553a9b589273fa3578d3cb12aa7a056f8639b341bd2ab44291
+DIST cdemu-daemon-3.2.5.tar.xz 85948 BLAKE2B f9b977ce964b15835afef54131cc158bc45389af30739706d93984bc24787b95034d9da7d56e88e018be9db66c185c16b7cf7481e0fdd0e97fed9e55b61419fd SHA512 6b084dc1809c9ccf8f9c24c671f13259d2e1ca6d2e6f7f85d44a47b4e973a68d7c92e470071421cdf6f2142eb26bdfd277a2f9c85b960d0b315b51a2d65953c7
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.2.5.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.5.ebuild
new file mode 100644
index 000000000000..ddfa7e43cf65
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake systemd
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="https://cdemu.sourceforge.io"
+SRC_URI="https://download.sourceforge.net/cdemu/cdemu-daemon/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-libs/glib-2.38:2
+ >=dev-libs/libmirage-3.2.0:=
+ >=media-libs/libao-0.8.0:="
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+src_install() {
+ cmake_src_install
+
+ insinto /etc/modules-load.d
+ newins - vhba.conf <<<"vhba"
+ systemd_douserunit service-example/cdemu-daemon.service
+ insinto /usr/share/dbus-1/services
+ doins service-example/net.sf.cdemu.CDEmuDaemon.service
+}
+
+pkg_postinst() {
+ elog "As of 3.2.5, cdemu-daemon no longer supports autoloading"
+ elog "on non-systemd systems. OpenRC users have to start it manually."
+ elog
+ elog "We install /etc/modules-load.d/vhba.conf to load the module"
+ elog "automatically, and D-BUS autolaunch will start cdemu-daemon user"
+ elog "service."
+}