summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-28 08:53:17 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-28 09:07:50 +0200
commitfaef7606e78eda0af5e64cabd43ef93218228102 (patch)
treeb0e0ff53a78bddec039934cc08dc24a2ada916da /app-cdr
parentapp-cdr/cdemu: Bump to 3.2.2 (diff)
downloadgentoo-faef7606e78eda0af5e64cabd43ef93218228102.tar.gz
gentoo-faef7606e78eda0af5e64cabd43ef93218228102.tar.bz2
gentoo-faef7606e78eda0af5e64cabd43ef93218228102.zip
app-cdr/cdemu-daemon: Bump to 3.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/cdemu-daemon/Manifest1
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-3.2.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-cdr/cdemu-daemon/Manifest b/app-cdr/cdemu-daemon/Manifest
index 38b795c19d4c..5ee31201b620 100644
--- a/app-cdr/cdemu-daemon/Manifest
+++ b/app-cdr/cdemu-daemon/Manifest
@@ -1 +1,2 @@
DIST cdemu-daemon-3.2.2.tar.bz2 82366 BLAKE2B d21436a5dbf1c6d953aa7ceb58e5d4580931391ea407c45de8f7c7154c181aef76535833bf02999d77d3a9e0c624db1124a9d333d028e206844a1256b3c5dde0 SHA512 4010bad27d5f595d20e1666700d32c2fb3f943f2e50645317bcc8fbbbba58cd61b3f6d3276e91fff55f449e44291abc776a56ded7c4f0bb7901ac247da72d7fe
+DIST cdemu-daemon-3.2.3.tar.bz2 83130 BLAKE2B 2be64beb662ebeb51d75a34bccece5f5eede8abe447d4d0be60bf1bbe4e1f9ac6eeaa67783f763f4966571cf4e13fb9b61610ead40d8a13842400f48bb3b1618 SHA512 a1c7fdea9e32e71591a29de98f28dd4d2d0ffb972861916ab287ff33f5f070da8fcc113b602e4b02fd08a72f7361ae85440ef5eb156e312a849cd716207026a7
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.2.3.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.3.ebuild
new file mode 100644
index 000000000000..37f3d7278bab
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-libs/glib-2.38:2
+ >=dev-libs/libmirage-3.2.0:=
+ >=media-libs/libao-0.8.0:="
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607"
+
+DOCS=( AUTHORS README )
+
+pkg_postinst() {
+ elog "You will need to load the vhba module to use cdemu devices:"
+ elog " # modprobe vhba"
+ elog "To automatically load the vhba module at boot time, edit your"
+ elog "/etc/conf.d/modules file."
+
+ if [[ -e "${ROOT}etc/conf.d/cdemud" ]]; then
+ elog
+ elog "${PN} no longer installs an init.d service; instead, it is"
+ elog "automatically activated when needed via dbus."
+ elog "You can therefore remove ${ROOT%/}/etc/conf.d/cdemud"
+ fi
+}