summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <rahil3108@gmail.com>2023-09-21 18:39:12 +0530
committerSam James <sam@gentoo.org>2023-09-21 23:16:18 +0100
commitd0df8ec928ddad7151ef9e1d76de5485a27cc178 (patch)
treec2eaf33c199c3dafffd8d7ecede57574c25609a1 /app-containers/containers-storage/containers-storage-1.42.0.ebuild
parentapp-containers/containers-image: add 5.28.0 and live (diff)
downloadgentoo-d0df8ec928ddad7151ef9e1d76de5485a27cc178.tar.gz
gentoo-d0df8ec928ddad7151ef9e1d76de5485a27cc178.tar.bz2
gentoo-d0df8ec928ddad7151ef9e1d76de5485a27cc178.zip
app-containers/containers-storage: drop 1.41.0 1.42.0
releasing 1.50.2 & live version in next commit Signed-off-by: Rahil Bhimjiani <rahil3108@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-containers/containers-storage/containers-storage-1.42.0.ebuild')
-rw-r--r--app-containers/containers-storage/containers-storage-1.42.0.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/app-containers/containers-storage/containers-storage-1.42.0.ebuild b/app-containers/containers-storage/containers-storage-1.42.0.ebuild
deleted file mode 100644
index c01863fdb218..000000000000
--- a/app-containers/containers-storage/containers-storage-1.42.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit go-module
-
-KEYWORDS="~amd64"
-DESCRIPTION="containers/storage library"
-HOMEPAGE="https://github.com/containers/storage"
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
-SLOT="0"
-IUSE="btrfs +device-mapper test"
-SRC_URI="https://github.com/containers/storage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RDEPEND="
- btrfs? ( sys-fs/btrfs-progs )
- device-mapper? ( sys-fs/lvm2:= )"
-DEPEND="${RDEPEND}
- dev-go/go-md2man
- test? (
- sys-fs/btrfs-progs
- sys-fs/lvm2
- sys-apps/util-linux
- )"
-RESTRICT="test"
-
-S=${WORKDIR}/${P#containers-}
-
-src_prepare() {
- default
-
- sed -e 's|: install\.tools|:|' -i Makefile || die
-
- [[ -f hack/btrfs_tag.sh ]] || die
- use btrfs || { echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
- "hack/btrfs_tag.sh" || die; }
-
- [[ -f hack/libdm_tag.sh ]] || die
- use device-mapper || { echo -e "#!/bin/sh\necho btrfs_noversion exclude_graphdriver_devicemapper" > \
- "hack/libdm_tag.sh" || die; }
-}
-
-src_compile() {
- export -n GOCACHE GOPATH XDG_CACHE_HOME #678856
- emake GOMD2MAN=go-md2man FFJSON= containers-storage docs
-}
-
-src_install() {
- dobin "${PN}"
- while read -r -d ''; do
- mv "${REPLY}" "${REPLY%.1}" || die
- done < <(find "${S}/docs" -name '*.[[:digit:]].1' -print0)
- find "${S}/docs" -name '*.[[:digit:]]' -exec doman '{}' + || die
-}
-
-src_test() {
- env -u GOFLAGS unshare -m emake local-test-unit || die
-}