summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-03-19 15:29:36 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-03-19 15:29:48 -0500
commit9ab1cd1b5a414869290595996b147e3f1269f0e0 (patch)
tree459daa166222910b360d9569e8b7c22a2dea1668 /app-containers/cosign/cosign-1.6.0.ebuild
parentdev-lua/lua-unbound: add missing deps (diff)
downloadgentoo-9ab1cd1b5a414869290595996b147e3f1269f0e0.tar.gz
gentoo-9ab1cd1b5a414869290595996b147e3f1269f0e0.tar.bz2
gentoo-9ab1cd1b5a414869290595996b147e3f1269f0e0.zip
app-containers/cosign: add 1.6.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers/cosign/cosign-1.6.0.ebuild')
-rw-r--r--app-containers/cosign/cosign-1.6.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-containers/cosign/cosign-1.6.0.ebuild b/app-containers/cosign/cosign-1.6.0.ebuild
new file mode 100644
index 000000000000..ce97639ed60d
--- /dev/null
+++ b/app-containers/cosign/cosign-1.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GIT_HASH=4b2c3c0c8ee97f31b9dac3859b40e0a48b8648ee
+inherit go-module
+
+DESCRIPTION="container signing utility"
+HOMEPAGE="https://sigstore.dev"
+SRC_URI="https://github.com/sigstore/cosign/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.0-fix-makefile.patch
+)
+
+src_compile() {
+ emake \
+ GIT_HASH=${GIT_HASH}
+ GIT_VERSION=v${PV} \
+ GIT_TREESTATE=clean
+}
+
+src_install() {
+ dobin cosign
+ einstalldocs
+}