summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-19 23:30:04 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-20 00:51:32 -0800
commit36286e6d06e223f2412757f408d9f77dde0fdc41 (patch)
tree023955f8f1b8a6cfb1aa1a8238d922cce2108ea8 /app-containers/cri-tools
parentMove {app-emulation -> app-containers}/cri-o (diff)
downloadgentoo-36286e6d06e223f2412757f408d9f77dde0fdc41.tar.gz
gentoo-36286e6d06e223f2412757f408d9f77dde0fdc41.tar.bz2
gentoo-36286e6d06e223f2412757f408d9f77dde0fdc41.zip
Move {app-emulation -> app-containers}/cri-tools
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-containers/cri-tools')
-rw-r--r--app-containers/cri-tools/Manifest2
-rw-r--r--app-containers/cri-tools/cri-tools-1.18.0.ebuild32
-rw-r--r--app-containers/cri-tools/cri-tools-1.21.0.ebuild34
-rw-r--r--app-containers/cri-tools/metadata.xml8
4 files changed, 76 insertions, 0 deletions
diff --git a/app-containers/cri-tools/Manifest b/app-containers/cri-tools/Manifest
new file mode 100644
index 000000000000..a7b995a38267
--- /dev/null
+++ b/app-containers/cri-tools/Manifest
@@ -0,0 +1,2 @@
+DIST cri-tools-1.18.0.tar.gz 5295512 BLAKE2B 9dda4a401b858e98aa60521d3268d8f6ff6a2c1bd2c219a0e5e9e5360fba58d41e97258c636da26ee57bbfc3286798c74107c7de92d3e3398bdf53b7d9078e94 SHA512 849b496e6d19eec29e0e56f0b37c094649311b80514f319b0c68c6519e3ddd48e1973c3d288144db998826676416644ec705b7ea0916c21898b40928ea800af1
+DIST cri-tools-1.21.0.tar.gz 6739482 BLAKE2B 365e3e9b220e63713dd21af4154b2282c20db1d19ba6b32da616c5d73957a375ab12ed2a86694abb9d90e1020be1fd89c128ed3e469d2f7524dcf42139e7df56 SHA512 a307f5526fb8b7b23a1635b168a8f3b9b9b4bd6ccb94d461dc5af2065e6d1be527dadcb1c86e04808b244d0851a4901ee78a0263f58cf673f6ca503621d5eb61
diff --git a/app-containers/cri-tools/cri-tools-1.18.0.ebuild b/app-containers/cri-tools/cri-tools-1.18.0.ebuild
new file mode 100644
index 000000000000..32412429f575
--- /dev/null
+++ b/app-containers/cri-tools/cri-tools-1.18.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 go-module
+MY_PV="v${PV/_beta/-beta.}"
+
+DESCRIPTION="CLI and validation tools for Kubelet Container Runtime (CRI)"
+HOMEPAGE="https://github.com/kubernetes-sigs/cri-tools"
+SRC_URI="https://github.com/kubernetes-sigs/cri-tools/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="amd64"
+
+RESTRICT+=" test"
+
+src_compile() {
+ emake VERSION="${MY_PV}"
+ _output/crictl completion bash > ${PN}.bash || die
+ _output/crictl completion zsh > ${PN}.zsh || die
+}
+
+src_install() {
+ dobin _output/crictl
+
+ newbashcomp ${PN}.bash ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ dodoc -r docs {README,RELEASE,CHANGELOG,CONTRIBUTING}.md
+}
diff --git a/app-containers/cri-tools/cri-tools-1.21.0.ebuild b/app-containers/cri-tools/cri-tools-1.21.0.ebuild
new file mode 100644
index 000000000000..b171220105c3
--- /dev/null
+++ b/app-containers/cri-tools/cri-tools-1.21.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="CLI and validation tools for Kubelet Container Runtime (CRI)"
+HOMEPAGE="https://github.com/kubernetes-sigs/cri-tools"
+SRC_URI="https://github.com/kubernetes-sigs/cri-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="amd64"
+
+DEPEND="dev-lang/go"
+
+RESTRICT+=" test"
+
+src_compile() {
+ emake VERSION="${PV}"
+ ./build/bin/crictl completion bash > "${PN}.bash" || die
+ ./build/bin/crictl completion zsh > "${PN}.zsh" || die
+}
+
+src_install() {
+ dobin ./build/bin/crictl
+
+ newbashcomp ${PN}.bash ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ dodoc -r docs {README,RELEASE,CHANGELOG,CONTRIBUTING}.md
+}
diff --git a/app-containers/cri-tools/metadata.xml b/app-containers/cri-tools/metadata.xml
new file mode 100644
index 000000000000..ebe162c4841a
--- /dev/null
+++ b/app-containers/cri-tools/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">kubernetes-sigs/cri-tools</remote-id>
+ </upstream>
+</pkgmetadata>