summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-19 23:26:45 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-20 00:51:23 -0800
commite0d5f4f032989ca6acf69b41778396be959e900f (patch)
treee9353927ef17fb3f86459df6b5f3cb6123f24e8d /app-containers/crun/crun-1.3.ebuild
parentdev-python/pip: Fix generating completions with vendored distutils (diff)
downloadgentoo-e0d5f4f032989ca6acf69b41778396be959e900f.tar.gz
gentoo-e0d5f4f032989ca6acf69b41778396be959e900f.tar.bz2
gentoo-e0d5f4f032989ca6acf69b41778396be959e900f.zip
Move {app-emulation -> app-containers}/crun
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-containers/crun/crun-1.3.ebuild')
-rw-r--r--app-containers/crun/crun-1.3.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-containers/crun/crun-1.3.ebuild b/app-containers/crun/crun-1.3.ebuild
new file mode 100644
index 000000000000..5de80d420e29
--- /dev/null
+++ b/app-containers/crun/crun-1.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-any-r1
+
+DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
+HOMEPAGE="https://github.com/containers/crun"
+SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="+bpf +caps criu +seccomp systemd static-libs"
+
+DEPEND="
+ dev-libs/yajl:=
+ sys-kernel/linux-headers
+ caps? ( sys-libs/libcap )
+ criu? ( >=sys-process/criu-3.15 )
+ seccomp? ( sys-libs/libseccomp )
+ systemd? ( sys-apps/systemd:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+# the crun test suite is comprehensive to the extent that tests will fail
+# within a sandbox environment, due to the nature of the privileges
+# required to create linux "containers".
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable bpf)
+ $(use_enable caps)
+ $(use_enable criu)
+ $(use_enable seccomp)
+ $(use_enable systemd)
+ $(usex static-libs '--enable-shared --enable-static' '--enable-shared --disable-static' '' '')
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake -C libocispec
+ emake crun
+}
+
+src_install() {
+ emake "DESTDIR=${D}" install-exec
+ doman crun.1
+ einstalldocs
+}