summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2022-05-14 00:47:33 +1000
committerSam James <sam@gentoo.org>2022-05-13 20:12:38 +0000
commit97316b5e6fa64cd54b7c465134b86e78fbfff0ca (patch)
tree2bb32206e82ceb73bb04144ea5d40780a6bd2e85 /app-containers/crun/crun-1.4.5.ebuild
parentsys-apps/fwts: keep old HOMEPAGE too (diff)
downloadgentoo-97316b5e6fa64cd54b7c465134b86e78fbfff0ca.tar.gz
gentoo-97316b5e6fa64cd54b7c465134b86e78fbfff0ca.tar.bz2
gentoo-97316b5e6fa64cd54b7c465134b86e78fbfff0ca.zip
app-containers/crun: add 1.4.5
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-containers/crun/crun-1.4.5.ebuild')
-rw-r--r--app-containers/crun/crun-1.4.5.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-containers/crun/crun-1.4.5.ebuild b/app-containers/crun/crun-1.4.5.ebuild
new file mode 100644
index 000000000000..e438b67454db
--- /dev/null
+++ b/app-containers/crun/crun-1.4.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-any-r1
+
+DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
+HOMEPAGE="https://github.com/containers/crun"
+SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv"
+IUSE="+bpf +caps criu +seccomp selinux systemd static-libs"
+
+DEPEND="
+ dev-libs/yajl:=
+ sys-kernel/linux-headers
+ caps? ( sys-libs/libcap )
+ criu? ( >=sys-process/criu-3.15 )
+ seccomp? ( sys-libs/libseccomp )
+ systemd? ( sys-apps/systemd:= )
+"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-container )"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+# the crun test suite is comprehensive to the extent that tests will fail
+# within a sandbox environment, due to the nature of the privileges
+# required to create linux "containers".
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable bpf)
+ $(use_enable caps)
+ $(use_enable criu)
+ $(use_enable seccomp)
+ $(use_enable systemd)
+ $(usex static-libs '--enable-shared --enable-static' '--enable-shared --disable-static' '' '')
+ )
+
+ # Need https://github.com/containers/libocispec/pull/107 to be merged & land in
+ # a crun release that syncs up w/ latest version, then can drop CONFIG_SHELL
+ CONFIG_SHELL="${BROOT}/bin/bash" econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake -C libocispec
+ emake crun
+}
+
+src_install() {
+ emake "DESTDIR=${D}" install-exec
+ doman crun.1
+ einstalldocs
+}