summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-06 15:34:26 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-06 17:20:50 +0200
commitd2ef18d590d1f76ad4341748ad72a27ddd0c83a0 (patch)
tree4d964bdd88a0f0199768b9bb0e213aeb455f7930 /app-containers/earthly
parentapp-containers/earthly: drop old 0.7.15 (diff)
downloadgentoo-d2ef18d590d1f76ad4341748ad72a27ddd0c83a0.tar.gz
gentoo-d2ef18d590d1f76ad4341748ad72a27ddd0c83a0.tar.bz2
gentoo-d2ef18d590d1f76ad4341748ad72a27ddd0c83a0.zip
app-containers/earthly: bump to 0.17.20
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers/earthly')
-rw-r--r--app-containers/earthly/Manifest2
-rw-r--r--app-containers/earthly/earthly-0.7.20.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index a0193b4587af..e84390093e0d 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -2,3 +2,5 @@ DIST earthly-0.7.17-deps.tar.xz 152916336 BLAKE2B c54a1b6166cd55ac8417004c50c742
DIST earthly-0.7.17.tar.gz 7755932 BLAKE2B e08d380673698e085cc5eb645337a709bf0ff3429f4565d15750e6f1d8aa82dc83d1f5c7aa155da163eb6b6376f275b171b88117b9a7903b23c1d7aba60fa38e SHA512 b495c5abf90397e044da3e394d859e02280c11b16f4c32f742624f7c97a51c597d32bdcc527cf5a99d4c5b09d1a238b7a6128d57e4be7cb0858e0f361fd0c597
DIST earthly-0.7.19-deps.tar.xz 152930992 BLAKE2B 436e66036a5772a8bb2f283522f064670b8bb9d8e811bf159db7c4a883d7a3be37e3acac3b003f21b806fe48a87b0aff9ea422b730b79c73d0ffcf08aeabc9c7 SHA512 154903533b406f8a2f4c7f7f41ad94ab09efd784c79ce4d579821e0d17dd9df5f783806d901e2c7a857467e4c543985847b379e167db57a0f5ed446ce78ec256
DIST earthly-0.7.19.tar.gz 7758683 BLAKE2B e81ca5c98bf92b69dff497202d9ec202d528422c16e435a90ef4758886f0b09ffed32e2a256e961db54aefd7549ba93d0983cddbb7cb878f747dcf4702fc1442 SHA512 b57215fd6dff2bbe4b2e559bc535746abdef6ddef9f808cce9519c6bff7578fb735923733ef2e4607fbbf00b9fcbde5a1f60cbb7098bc66b12165749d9404d84
+DIST earthly-0.7.20-deps.tar.xz 152928984 BLAKE2B f7a17986f79c5557fa92313d4405fbfd048462933bdf2a798065f443a9f8a9d60e47a78a51580eec3a779c77147a06314742221910ca855eb580194a9d072395 SHA512 59be72396b9241e6d59fc17628b97ea962e43d119587a2a92f84715105006f96f94c6f394703f4efaba07e04eeaa4fae223bab257d00275360b217b0c614920a
+DIST earthly-0.7.20.tar.gz 7768141 BLAKE2B 6a00cd29ca6b6066d432342218f37ac27fcdf494dd7190b3c0ac590a0d13f01efcd5d7af9a51f39cc2b60071b25a346c6574d3b81b7c072c57db99ee303f8899 SHA512 be917a5d34dc7929616a9f708b39863b1de791e59a1b5940413a6245a9c4878b477a85dec20b47ab08e3662da5bc90096f86202a4f37c303291ce65d497a8aa9
diff --git a/app-containers/earthly/earthly-0.7.20.ebuild b/app-containers/earthly/earthly-0.7.20.ebuild
new file mode 100644
index 000000000000..f4218dbca820
--- /dev/null
+++ b/app-containers/earthly/earthly-0.7.20.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Git commit SHA is needed at runtime by earthly to pull and bootstrap images.
+if [[ "${PV}" == 0.7.20 ]] ; then
+ GIT_COMMIT_SHA="9600f376026c11d23eb43fc68ad716d6ae4cca2e"
+else
+ die 'Could not detect "GIT_COMMIT_SHA", please update the ebuild.'
+fi
+
+inherit go-module
+
+DESCRIPTION="Build automation tool that executes in containers"
+HOMEPAGE="https://earthly.dev/
+ https://github.com/earthly/earthly/"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+src_compile() {
+ mkdir -p bin || die
+
+ local go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
+ local go_ldflags="
+ -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
+ -X main.GitSha=${GIT_COMMIT_SHA}
+ -X main.Version=v${PV}
+ "
+ local -a go_buildargs=(
+ -tags "${go_tags}"
+ -ldflags "${go_ldflags}"
+ -o bin
+ )
+ ego build "${go_buildargs[@]}" ./cmd/...
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe bin/earthly
+ newexe bin/debugger earthly-debugger
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if has_version "app-containers/podman" ; then
+ ewarn "Podman is supported but not recommended."
+ ewarn "If issues arise, then please try running earthly with docker."
+ fi
+
+ if has_version "app-containers/podman[rootless]" ; then
+ ewarn "Running podman in rootless mode is not supported because"
+ ewarn "earthly/dind and earthly/buildkit require privileged access."
+ ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
+ fi
+}