summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-09-12 17:08:31 -0700
committerZac Medico <zmedico@gentoo.org>2022-09-12 17:08:37 -0700
commitf67f1e5edce38e34bd2f0c71e5cc1f9a3e46f922 (patch)
treee54fcf28cb60a564950196964a64d78b27ed4e44 /app-containers/nerdctl/nerdctl-0.23.0.ebuild
parentapp-containers/nerdctl: drop 0.17.1, 0.18.0, 0.19.0, 0.21.0, 0.22.0 (diff)
downloadgentoo-f67f1e5edce38e34bd2f0c71e5cc1f9a3e46f922.tar.gz
gentoo-f67f1e5edce38e34bd2f0c71e5cc1f9a3e46f922.tar.bz2
gentoo-f67f1e5edce38e34bd2f0c71e5cc1f9a3e46f922.zip
app-containers/nerdctl: add 0.23.0
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers/nerdctl/nerdctl-0.23.0.ebuild')
-rw-r--r--app-containers/nerdctl/nerdctl-0.23.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-containers/nerdctl/nerdctl-0.23.0.ebuild b/app-containers/nerdctl/nerdctl-0.23.0.ebuild
new file mode 100644
index 000000000000..93e8df5fdcff
--- /dev/null
+++ b/app-containers/nerdctl/nerdctl-0.23.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+DESCRIPTION="Docker-compatible CLI for containerd, with support for Compose"
+HOMEPAGE="https://github.com/containerd/nerdctl"
+
+EGIT_COMMIT="660680b7ddfde1d38a66ec1c7f08f8d89ab92c68"
+# There are too many vendor dependencies to distribute via EGO_SUM (see https://bugs.gentoo.org/721088),
+# so they are instead distributed via a combined tarball.
+SRC_URI="https://github.com/zmedico/nerdctl/archive/refs/tags/v${PV}-vendor.tar.gz -> ${P}-vendor.tar.gz"
+BDEPEND=">=dev-lang/go-1.16"
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT"
+SLOT="0"
+
+KEYWORDS="~amd64"
+IUSE=""
+S=${WORKDIR}/${P}-vendor
+
+src_prepare() {
+ sed -e 's:/usr/local/bin:/usr/bin:' \
+ -e "s|^VERSION[[:space:]]*=.*|VERSION := v${PV}|" \
+ -e "s|^REVISION[[:space:]]*=.*|REVISION := ${EGIT_COMMIT}|" \
+ -i Makefile || die
+ default
+}
+
+src_install() {
+ DOCS=(README.md docs examples)
+ default_src_install
+}