summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-07-17 11:02:50 -0700
committerZac Medico <zmedico@gentoo.org>2022-07-17 11:03:08 -0700
commit16c4b56d5481f0a2ac03a3257a994a980b226181 (patch)
tree6e3e57638dbfc99c20a446ae0457a1f13a50c10a /app-containers/nerdctl
parentwww-servers/moonbridge: fix DEPS (diff)
downloadgentoo-16c4b56d5481f0a2ac03a3257a994a980b226181.tar.gz
gentoo-16c4b56d5481f0a2ac03a3257a994a980b226181.tar.bz2
gentoo-16c4b56d5481f0a2ac03a3257a994a980b226181.zip
app-containers/nerdctl: add 0.22.0
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers/nerdctl')
-rw-r--r--app-containers/nerdctl/Manifest1
-rw-r--r--app-containers/nerdctl/nerdctl-0.22.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-containers/nerdctl/Manifest b/app-containers/nerdctl/Manifest
index 009a6ddbb36b..9d53aeb3f7fa 100644
--- a/app-containers/nerdctl/Manifest
+++ b/app-containers/nerdctl/Manifest
@@ -2,3 +2,4 @@ DIST nerdctl-0.17.1-vendor.tar.gz 7762770 BLAKE2B 399a99047cb3a3ab31806529e2502f
DIST nerdctl-0.18.0-vendor.tar.gz 7757873 BLAKE2B dfc77baee4649cf5a4ffa2ae196460d34eea531f930f04b894cc715b68a4295d1bcf98c89702032aaf6c5fc0b1a7f8b885f6c4b0bd61afd044b67fe4510c6967 SHA512 b542abafbd1dfe4213646b66b69d7bb286b8fda152870846cd350ad0362cbd16ca5f2d8fe23ae056f0c18f5674eb984f2993cf2937d7aff7b67668d65d9e1488
DIST nerdctl-0.19.0-vendor.tar.gz 7798588 BLAKE2B 1bf17d09de13e5d2160cca500e8d9dc2eb666f5639e12353e1153bbf201f48d376c7b369a97bd851082c32276c6ba280d8f8e1add7b56206d3f07a0dfc725393 SHA512 9f84d829c2c40589f930345bb7073e6ca868e9e840f74c9176b049b63b2983dca55168eb54113b7b74e7651f1c902f84c9fca8d0f5d948ba7510db91f3a52e74
DIST nerdctl-0.21.0-vendor.tar.gz 7984755 BLAKE2B e28b260667109604edb8b0f0c090fcb9769dd4a7411843f2d6180a3bb6f3165ca8feb3c4798c78f2eb2134bc9a205e263e8098e80a6fe0f0de5641b13158d7f8 SHA512 174f8dc8be631eef84d7c461bf4a797fc6d47b20385286cedbbb769c764a97a64937fb2a104c45f42459c4b2217b6fe2bb534f07153a6761f59798d2a08490e0
+DIST nerdctl-0.22.0-vendor.tar.gz 8330256 BLAKE2B d85e7f2938dbaec1ba247d7d3d889bd24fa9e008fc12295a3cd9f8578ebe1f2a3f1d52a23e147ad912fbbd2ccb5c1a796f621285d21f33fb449394ebb449ca0c SHA512 850079c686a0a4ae1616f42f84fed5a4280e0bc0df12ab50f8f883265bc3c04d82081e4a0aa8585673945d6185d2c79cbf07ce1157e794a9b7891b6be1fdff65
diff --git a/app-containers/nerdctl/nerdctl-0.22.0.ebuild b/app-containers/nerdctl/nerdctl-0.22.0.ebuild
new file mode 100644
index 000000000000..f2b3218e9d28
--- /dev/null
+++ b/app-containers/nerdctl/nerdctl-0.22.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+DESCRIPTION="Docker-compatible CLI for containerd, with support for Compose"
+HOMEPAGE="https://github.com/containerd/nerdctl"
+
+EGIT_COMMIT="8e278e2aa61a89d4e50d1a534217f264bd1a5ddf"
+# There are too many vendor dependencies to distribute via EGO_SUM (see https://bugs.gentoo.org/721088),
+# so they are instead distributed via a combined tarball.
+SRC_URI="https://github.com/zmedico/nerdctl/archive/refs/tags/v${PV}-vendor.tar.gz -> ${P}-vendor.tar.gz"
+BDEPEND=">=dev-lang/go-1.16"
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT"
+SLOT="0"
+
+KEYWORDS="~amd64"
+IUSE=""
+S=${WORKDIR}/${P}-vendor
+
+src_prepare() {
+ sed -e 's:/usr/local/bin:/usr/bin:' \
+ -e "s|^VERSION[[:space:]]*=.*|VERSION := v${PV}|" \
+ -e "s|^REVISION[[:space:]]*=.*|REVISION := ${EGIT_COMMIT}|" \
+ -i Makefile || die
+ default
+}
+
+src_install() {
+ DOCS=(README.md docs examples)
+ default_src_install
+}