summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandall <ran.dall@icloud.com>2022-02-26 09:21:55 -0800
committerZac Medico <zmedico@gentoo.org>2022-02-26 09:27:00 -0800
commit7db621ca2f8ef75a11f6d98086fd4c7c49ef37a9 (patch)
tree571b4b91a249b37719d83980bfbba00df27c34ef /app-containers/snapd
parentdev-python/pyzotero: Migrate to PEP517 build (diff)
downloadgentoo-7db621ca2f8ef75a11f6d98086fd4c7c49ef37a9.tar.gz
gentoo-7db621ca2f8ef75a11f6d98086fd4c7c49ef37a9.tar.bz2
gentoo-7db621ca2f8ef75a11f6d98086fd4c7c49ef37a9.zip
app-containers/snapd: Handle -O3
Closes: https://bugs.gentoo.org/834055 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers/snapd')
-rw-r--r--app-containers/snapd/snapd-2.54.3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-containers/snapd/snapd-2.54.3.ebuild b/app-containers/snapd/snapd-2.54.3.ebuild
index 6366a2d391fc..bf6b2a0a243e 100644
--- a/app-containers/snapd/snapd-2.54.3.ebuild
+++ b/app-containers/snapd/snapd-2.54.3.ebuild
@@ -4,7 +4,7 @@
EAPI=7
EGO_PN="github.com/snapcore/${PN}"
-inherit autotools bash-completion-r1 golang-vcs-snapshot linux-info readme.gentoo-r1 systemd xdg-utils
+inherit autotools bash-completion-r1 flag-o-matic golang-vcs-snapshot linux-info readme.gentoo-r1 systemd xdg-utils
DESCRIPTION="Service and tools for management of snap packages"
HOMEPAGE="http://snapcraft.io/"
@@ -61,6 +61,9 @@ pkg_setup() {
CONFIG_CHECK+=" ~SECURITY_APPARMOR"
fi
linux-info_pkg_setup
+
+ # Seems to have issues building with -O3, switch to -O2
+ replace-flags -O3 -O2
}
src_prepare() {