summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2023-02-21 17:29:33 -0800
committerZac Medico <zmedico@gentoo.org>2023-02-21 17:29:37 -0800
commitd5af529eebb4ad95f05a1e11129c1b2c749786ea (patch)
treec21406214a32602df47d1d7990114390dc10b6a7 /app-containers
parentsys-fs/fuse-overlayfs: add 1.10 (diff)
downloadgentoo-d5af529eebb4ad95f05a1e11129c1b2c749786ea.tar.gz
gentoo-d5af529eebb4ad95f05a1e11129c1b2c749786ea.tar.bz2
gentoo-d5af529eebb4ad95f05a1e11129c1b2c749786ea.zip
app-containers/buildah: add 1.29.1
Closes: https://bugs.gentoo.org/895456 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/buildah/Manifest1
-rw-r--r--app-containers/buildah/buildah-1.29.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-containers/buildah/Manifest b/app-containers/buildah/Manifest
index b75b3bc0ab0d..7af4844dc31c 100644
--- a/app-containers/buildah/Manifest
+++ b/app-containers/buildah/Manifest
@@ -1,3 +1,4 @@
DIST buildah-1.27.1.tar.gz 14825932 BLAKE2B bf290eeb4d96d255c7cdaa07af49eff44191664ac7dee255c7979656383daaa93c3673ba82ac1cbff033de769ffa08ad027f5d91c81b08a36222cb73e8a1e399 SHA512 a5e2ddf837e613554ffe8fe9c15ac9c8f9c2564c403e5544df7fb8802962581fb4e9dd4361c28c93443ede74c20c82f1631990e443c7895a3b4c3b8a659ee05a
DIST buildah-1.28.0.tar.gz 14579386 BLAKE2B effc7d0a154e30790585c19e19655f98026c34687e79b91777700bc2f387b96896d88855cd5ec34573dd2678e4a30a832c39f789d53b61b45cb5f682dacd252e SHA512 f5e82a22648fa0d0ba7f5dcf3b97a2ec1182f31d3e03cd2624e01fe76fcdddf0a5605c59816eeef6401d151864b6b6be493c144b83f5667ab3947eea902f0086
DIST buildah-1.28.1.tar.gz 14576193 BLAKE2B 5317b991780b0c2539802495a2a15e91d4e1623700d0a3fa354e362bd647e59a0e9c34d8f19858e129d0028c71bb04665bde7668e3b5f3f3e5b85c944f7108b5 SHA512 c674a90a0cae2977b76c2b68c06a0006f89d74b5b41362c2512a3f8d7ba515c3bd693648a0ba955dad7bea1a43da6890d80855e1283f0fc0136d16d77a798fba
+DIST buildah-1.29.1.tar.gz 15594930 BLAKE2B 71b87352062b3a5df67389897fd0d82c2491c48cffbda808b30e2767a1e290eccfd726be26dbd57fd8d08cfacb74f313058179c40600225d863a9340b772df1e SHA512 ea78aacee9b5cc10e299789d739e7086579e67719ab72b84f6ea5acbaf31d443284387ac92e7c5c1c3da9bd6523f43e2d9c7e2ea5698c251cb5458a384f41b04
diff --git a/app-containers/buildah/buildah-1.29.1.ebuild b/app-containers/buildah/buildah-1.29.1.ebuild
new file mode 100644
index 000000000000..21c3a103bda8
--- /dev/null
+++ b/app-containers/buildah/buildah-1.29.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit bash-completion-r1 go-module
+GIT_COMMIT=faf0d4fc
+
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="selinux"
+
+RDEPEND="app-crypt/gpgme:=
+ app-containers/skopeo
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-apps/shadow:=
+ sys-fs/lvm2:=
+ sys-libs/libseccomp:=
+ selinux? ( sys-libs/libselinux:= )"
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ [[ -f selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ selinux_tag.sh || die; }
+ sed -i -e 's/make -C/$(MAKE) -C/' Makefile || die 'sed failed'
+}
+
+src_compile() {
+ emake GIT_COMMIT=${GIT_COMMIT} all
+}
+
+src_install() {
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
+ doman docs/*.1
+ dodoc -r docs/tutorials
+ dobin bin/{${PN},imgtype}
+ dobashcomp contrib/completions/bash/buildah
+}
+
+src_test() {
+ emake test-unit
+}