summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-05-15 15:06:47 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-05-17 09:31:53 -0500
commite16ccc7540b50cd9a29101e304770df42a73d768 (patch)
tree26bfbff236434a7ee305efb87dd369429ff898fe /app-containers
parentapp-containers/docker-proxy: add 0.8.0_p20220315 (diff)
downloadgentoo-e16ccc7540b50cd9a29101e304770df42a73d768.tar.gz
gentoo-e16ccc7540b50cd9a29101e304770df42a73d768.tar.bz2
gentoo-e16ccc7540b50cd9a29101e304770df42a73d768.zip
app-containers/containerd: add 1.6.4
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/containerd/Manifest2
-rw-r--r--app-containers/containerd/containerd-1.6.4.ebuild85
2 files changed, 87 insertions, 0 deletions
diff --git a/app-containers/containerd/Manifest b/app-containers/containerd/Manifest
index a74243f69dde..cc91c05a33a2 100644
--- a/app-containers/containerd/Manifest
+++ b/app-containers/containerd/Manifest
@@ -1,3 +1,5 @@
DIST containerd-1.5.11.tar.gz 7494477 BLAKE2B 2415e85694e5f4410c8cee7be08d1d304adfcdb95c4078f7a92c710a5a11a29ae011daa70fcfa72c2fabf5b48b7cac962b39121f18bb027931ef77214e86b1aa SHA512 6348f4ae7f9b473aac7d5e7325ca4539345d09f01b95383cec28f09d5e5b0b831e25fe305c3a15050f1e1959948ee8dcad788a1d6dd4780cf3077132d5617ef8
DIST containerd-1.6.2-deps.tar.xz 99095488 BLAKE2B a8ab5b2a506cb90cbadba9461d2737b1ac0bea672681e3f940d1dc76fdd2885d1ab287129a2aaa2fab64d19ba049eb7ecdffbafa6b08772430b94428a775a042 SHA512 2a96405c28a6ebaeae523ef36b4721f493332953880bfb7cecc4571b325557f2566141a62c0eb5c981045d498dd18ad18f8e7adfd9d5f17218a5d5d65760b855
DIST containerd-1.6.2.tar.gz 8617797 BLAKE2B aaf16dbbd071f4eab45bc94cc50643b33665b5c4a4155ef007b7a974e04660235b69e12d99e78c24b27c09d45c0eb6e9be3d688b41592a54497a0a4e5f577c86 SHA512 3ff280ae0cf5a45b0c21a42290c94bad30d46bf8a5bbcef1024e3c67fde3345a31b23a88cdbb6025d526c93e2a0899e9b341c9b8ccbba381983de3d8a39b1046
+DIST containerd-1.6.4-deps.tar.xz 96520056 BLAKE2B 695e26ffc26c0d85350c91412b746f59d7edd556aef2fea71a8947b79e0cdba573503a19b45ddc4a733b721be6cef581ab22e7522d00ab9221a1322d5b9670a4 SHA512 439bad6067939ab97115c0cf85d8eafd1214435f78bc57ee6a3d60e606da1260153d871e50de7b31fb57dc293e2f1ffa083cf89d08a394ee99450effda309678
+DIST containerd-1.6.4.tar.gz 8625617 BLAKE2B b3766eec306a4e4b27849aa3131c0adf84e040c9b6b843bc2b231a13f5f1b6222035e4a7d2315170b0a001be60874544bbe2920bf4cda951aac48217efb3de28 SHA512 a913dbfdcf29faebd5617f64e7c5e62b366cb9c80d0dbf55337121601f3c5b7d19c1670f71e9454513b681a1568c7cd1fc28c5daf3ea1c820279f2a2356ff8c6
diff --git a/app-containers/containerd/containerd-1.6.4.ebuild b/app-containers/containerd/containerd-1.6.4.ebuild
new file mode 100644
index 000000000000..bcc9928fb160
--- /dev/null
+++ b/app-containers/containerd/containerd-1.6.4.ebuild
@@ -0,0 +1,85 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GIT_REVISION=212e8b6fa2f44b9c21b2798135fc6fb7c53efc16
+inherit go-module systemd
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.io/"
+SRC_URI="https://github.com/containerd/containerd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="apparmor btrfs device-mapper +cri hardened +seccomp selinux test"
+
+DEPEND="
+ btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp )
+"
+
+# recommended version of runc is found in script/setup/runc-version
+RDEPEND="
+ ${DEPEND}
+ ~app-containers/runc-1.1.2
+"
+
+BDEPEND="
+ dev-go/go-md2man
+ virtual/pkgconfig
+"
+
+# tests require root or docker
+# upstream does not recommend stripping binary
+RESTRICT+=" strip test"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s/-s -w//" \
+ Makefile || die
+ sed -i \
+ -e "s:/usr/local:/usr:" \
+ containerd.service || die
+}
+
+src_compile() {
+ local options=(
+ $(usev apparmor)
+ $(usex btrfs "" "no_btrfs")
+ $(usex cri "" "no_cri")
+ $(usex device-mapper "" "no_devmapper")
+ $(usev seccomp)
+ $(usev selinux)
+ )
+
+ myemakeargs=(
+ BUILDTAGS="${options[*]}"
+ LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')"
+ REVISION="${GIT_REVISION}"
+ VERSION=v${PV}
+ )
+
+ # race condition in man target https://bugs.gentoo.org/765100
+ # we need to explicitly specify GOFLAGS for "go run" to use vendor source
+ emake "${myemakeargs[@]}" man -j1 #nowarn
+ emake "${myemakeargs[@]}" all
+
+}
+
+src_install() {
+ dobin bin/*
+ doman man/*
+ newinitd "${FILESDIR}"/${PN}.initd "${PN}"
+ systemd_dounit containerd.service
+ keepdir /var/lib/containerd
+
+ # we already installed manpages, remove markdown source
+ # before installing docs directory
+ rm -r docs/man || die
+
+ local DOCS=( ADOPTERS.md README.md RELEASES.md ROADMAP.md SCOPE.md docs/. )
+ einstalldocs
+}