summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-05-17 10:15:29 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-05-17 10:15:29 -0500
commite2ab05ab5080709efba7fc539d85464a131d56df (patch)
treedfbe54cd415d0b86061afb98b3e595ad50559279 /app-containers
parentapp-containers/docker: add 20.10.16 (diff)
downloadgentoo-e2ab05ab5080709efba7fc539d85464a131d56df.tar.gz
gentoo-e2ab05ab5080709efba7fc539d85464a131d56df.tar.bz2
gentoo-e2ab05ab5080709efba7fc539d85464a131d56df.zip
app-containers/docker-cli: add 20.10.16
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/docker-cli/Manifest1
-rw-r--r--app-containers/docker-cli/docker-cli-20.10.16.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-containers/docker-cli/Manifest b/app-containers/docker-cli/Manifest
index b033552020c4..c8097a11c4a3 100644
--- a/app-containers/docker-cli/Manifest
+++ b/app-containers/docker-cli/Manifest
@@ -1,2 +1,3 @@
DIST docker-cli-20.10.12.tar.gz 7527161 BLAKE2B 34a90f6df9f43507461307817e72cfb9e37f88d00e6fc50b8b16f3db9c573e54edc2eb2641ff4e091a2a73e936f8844011520efe5aaec37a9eb9880f5f81c51a SHA512 ac7c997f5751f2e34b9bcb9f026d3d0c2cd58c32a13e9255536b0eb0d7eabd81c42f2d608c0fe7725322b619f2360818b08379e847d598dd0bec570602ad224f
DIST docker-cli-20.10.14.tar.gz 7508390 BLAKE2B b268a329450540c2e94eced7e7b7bb9387cd208c68bde82607fc56e1f0529d8ca35bb8c16839154443d950c21b0625a13aa8547d9f3053ed19645da683f14419 SHA512 f8b7f1040eccd404e39ec33bcef8bb8423636b0695af65f84c0612e77223844892d219f82cfbb99ccd5326e228f8af27be1870d90ebace77810ea5fce9f86e4a
+DIST docker-cli-20.10.16.tar.gz 7635926 BLAKE2B eb7ecde2770bb4e937f40b885604f5daa996f5644f78881d9814ae3cdfc7a0eec107519ef24bbabe0c726c8c83eaa475667fa251c3e9346fec597069ec36ba2e SHA512 90451f71f16f3bd1410b13c5df256ef1f422dd5b9b75d63cf318ee91a07bcb3ddb2876d2fee81e835d8daaee48c4e010c2daf4373de1095e2075fed8ee5fe75e
diff --git a/app-containers/docker-cli/docker-cli-20.10.16.ebuild b/app-containers/docker-cli/docker-cli-20.10.16.ebuild
new file mode 100644
index 000000000000..e4d344cc3d8b
--- /dev/null
+++ b/app-containers/docker-cli/docker-cli-20.10.16.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GIT_COMMIT=aa7e414fdc
+EGO_PN="github.com/docker/cli"
+MY_PV=${PV/_/-}
+inherit bash-completion-r1 golang-vcs-snapshot
+
+DESCRIPTION="the command line binary for docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="https://github.com/docker/cli/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="hardened selinux"
+
+RDEPEND="!<app-containers/docker-20.10.1
+ selinux? ( sec-policy/selinux-docker )"
+BDEPEND="
+ >=dev-lang/go-1.16.6
+ dev-go/go-md2man"
+
+RESTRICT="installsources strip test"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_prepare() {
+ default
+ sed -i 's@dockerd\?\.exe@@g' contrib/completion/bash/docker || die
+}
+
+src_compile() {
+ export DISABLE_WARN_OUTSIDE_CONTAINER=1
+ export GOPATH="${WORKDIR}/${P}"
+ # setup CFLAGS and LDFLAGS for separate build target
+ # see https://github.com/tianon/docker-overlay/pull/10
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
+ export CGO_LDFLAGS="-L${ESYSROOT}/usr/$(get_libdir)"
+ emake \
+ LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')" \
+ VERSION="${PV}" \
+ GITCOMMIT="${GIT_COMMIT}" \
+ dynbinary
+
+ # build man pages
+ # see "cli/scripts/docs/generate-man.sh" (which also does "go get" for go-md2man)
+ mkdir -p ./man/man1 || die "mkdir failed"
+ go build -o "${T}"/gen-manpages ./man ||
+ die 'build gen-manpages failed'
+ "${T}"/gen-manpages --root "$(pwd)" --target "$(pwd)"/man/man1 ||
+ die 'gen-manpages failed'
+ ./man/md2man-all.sh -q ||
+ die 'md2man-all.sh failed'
+}
+
+src_install() {
+ dobin build/docker
+ doman man/man*/*
+ dobashcomp contrib/completion/bash/*
+ bashcomp_alias docker dockerd
+ insinto /usr/share/fish/vendor_completions.d/
+ doins contrib/completion/fish/docker.fish
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/_*
+}