summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-02-21 11:02:32 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-02-21 11:02:52 -0600
commitf156536de0a02369d4ecd1e8018210617c8b9d63 (patch)
tree1bfca0d49ee54a8124b249d19b350b79b84a5a43 /app-containers
parentdev-libs/nspr: Stabilize 4.35-r1 ppc, #895736 (diff)
downloadgentoo-f156536de0a02369d4ecd1e8018210617c8b9d63.tar.gz
gentoo-f156536de0a02369d4ecd1e8018210617c8b9d63.tar.bz2
gentoo-f156536de0a02369d4ecd1e8018210617c8b9d63.zip
app-containers/skopeo: add 1.11.1
Closes: https://bugs.gentoo.org/895452 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/skopeo/Manifest1
-rw-r--r--app-containers/skopeo/skopeo-1.11.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-containers/skopeo/Manifest b/app-containers/skopeo/Manifest
index 2b3b7c79c482..fe73fbdd706e 100644
--- a/app-containers/skopeo/Manifest
+++ b/app-containers/skopeo/Manifest
@@ -1,2 +1,3 @@
DIST skopeo-1.10.0.tar.gz 6460856 BLAKE2B b904a161334ef0a3eaaab8c58f0c7e4c507fa68a09f8fa8235e8a9222d48c98874c9ce878a509e2816f210ffb37dbf707ff2653212e1efbd9ad6686efb97e147 SHA512 0d64e7f12a0d10c81074a04b6c74ed6e7213f598013f1ba672c4c696e9dad5827f41f41bb817263bf8606cd051b8e24e7eab65b95d73d8a1c8bbb3eaeb9defdb
+DIST skopeo-1.11.1.tar.gz 8071084 BLAKE2B 2411db318e377cfcfa9a80523c0bd4900201b1c17a4fe0f875dd78033bd4241e6c806816746ef77304e2edbc3737a3b22cfa83b83d65eb3c462cd5437de4e0b8 SHA512 521a2c8ddf629e361340a51d95200ec67bc4fef814e0449b6d679725536ec9448827229d4f993276f084269c2ec73c1b4edf97c0ce29122d950d350ed623a4b9
DIST skopeo-1.5.1.tar.gz 5636533 BLAKE2B 7f0e86cdee5c3250ec1280d7e71554ac2f8ad96ababe0e81dfabc00e8c128a13fc0c9c561b7a9be389d7386e9f664b95118bd2122612b9c2e8844db49769c03c SHA512 3f8c730eaa739bf2a29b82d3b04aa4eee1c09f957b61964fc8c48e59d1537bcb87b5bdf9c18fa48f9d36cf2b7ede3a1448918a20b5a3167f6ce09881a6cd3dde
diff --git a/app-containers/skopeo/skopeo-1.11.1.ebuild b/app-containers/skopeo/skopeo-1.11.1.ebuild
new file mode 100644
index 000000000000..98396d981315
--- /dev/null
+++ b/app-containers/skopeo/skopeo-1.11.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+COMMIT=ee60474d5a4d99745aac9855797ad4b26510d786
+inherit go-module
+
+DESCRIPTION="Command line utility foroperations on container images and image repositories"
+HOMEPAGE="https://github.com/containers/skopeo"
+SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="btrfs"
+
+COMMON_DEPEND=">=app-crypt/gpgme-1.5.5:=
+ >=dev-libs/libassuan-2.4.3:=
+ dev-libs/libgpg-error:=
+ btrfs? ( >=sys-fs/btrfs-progs-4.0.1 )
+ >=sys-fs/lvm2-2.02.145:="
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+ BDEPEND="dev-go/go-md2man"
+
+RESTRICT="test"
+
+src_compile() {
+ local BUILDTAGS
+ BUILDTAGS="containers_image_ostree_stub $(usex btrfs "" exclude_graphdriver_btrfs)"
+ emake PREFIX=/usr BUILDTAGS="${BUILDTAGS}" GIT_COMMIT="${COMMIT}" \
+ all completions
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${ED}" install
+ keepdir /var/lib/containers/sigstore
+}