summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-04-05 15:06:22 +0100
committerMarek Szuba <marecki@gentoo.org>2023-04-05 15:06:56 +0100
commitf2b5111a4c249a9e209f4751680d921620e111dd (patch)
treedb49e2db4afc7cfbe0230f098f0babb49d2dde1b /app-containers
parentdev-libs/libxmlb: drop 0.3.10 (diff)
downloadgentoo-f2b5111a4c249a9e209f4751680d921620e111dd.tar.gz
gentoo-f2b5111a4c249a9e209f4751680d921620e111dd.tar.bz2
gentoo-f2b5111a4c249a9e209f4751680d921620e111dd.zip
app-containers/apptainer: drop 1.1.2
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/apptainer/Manifest1
-rw-r--r--app-containers/apptainer/apptainer-1.1.2.ebuild90
2 files changed, 0 insertions, 91 deletions
diff --git a/app-containers/apptainer/Manifest b/app-containers/apptainer/Manifest
index 11aee5642965..2a1ccd1811a5 100644
--- a/app-containers/apptainer/Manifest
+++ b/app-containers/apptainer/Manifest
@@ -1,3 +1,2 @@
-DIST apptainer-1.1.2.tar.gz 12896912 BLAKE2B 29a8df78617661e0a181955942e8321c112a69efaf15f4bb3e1563cc0789197916a3be1eb5396fb608d57b0edd5d5de2a70a2bda935095d8d511410660ebc106 SHA512 3fad253379a87ea790f22a14aec703296f606255d4ce847454a59f9dba0b9a6fc449489e7760c4696c1df90fc6abec198934310c1b762e33a83c72cafc7cb370
DIST apptainer-1.1.6.tar.gz 12914465 BLAKE2B a04ed9b9b429d7885d6c91f72d574d2a3a2955fdbe5cb2d30b59744b1f3bfb6f7d4f07ce7f1863caa83fb3361d7fdd2739b82334458d606ce053de43e1e9f755 SHA512 dd38abe1e343352e29a8a1fd1922901e4d48282fef641c75360253392ad53c6f1e5f7510ef612594e29db5f090fb41ff55b9d52d126be253450b0630fc7d383b
DIST apptainer-1.1.7.tar.gz 12926719 BLAKE2B ed12ae933166f03742c04551f3b231458e9ccd2d62184e965f91ab6f996bd32aa53b4efd6552e8f83a3735ff38bd48cb9c4450b9b6da064fe9029ea15555282e SHA512 10a4faa28f08961d483a63384671388d14ceedb150af752da576c035be79372401fd6ddb2eb5491569bb79b250c0f1e89e1b747463defc4a7f495610ebf2d371
diff --git a/app-containers/apptainer/apptainer-1.1.2.ebuild b/app-containers/apptainer/apptainer-1.1.2.ebuild
deleted file mode 100644
index 2773ffd53fba..000000000000
--- a/app-containers/apptainer/apptainer-1.1.2.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit linux-info toolchain-funcs
-
-DESCRIPTION="The container system for secure high-performance computing"
-HOMEPAGE="https://apptainer.org/"
-SRC_URI="https://github.com/apptainer/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples +network suid systemd"
-
-# Do not complain about CFLAGS etc. since go projects do not use them.
-QA_FLAGS_IGNORED='.*'
-
-DEPEND="app-crypt/gpgme
- >=dev-lang/go-1.17.6
- dev-libs/openssl
- sys-apps/util-linux
- sys-fs/cryptsetup
- sys-fs/squashfs-tools
- sys-libs/libseccomp
- !suid? (
- sys-fs/e2fsprogs[fuse]
- sys-fs/squashfuse
- )"
-RDEPEND="${DEPEND}
- !sys-cluster/singularity"
-BDEPEND="virtual/pkgconfig"
-
-CONFIG_CHECK="~SQUASHFS"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.0.2-trim_upstream_cflags.patch
-)
-
-DOCS=( README.md CONTRIBUTORS.md CONTRIBUTING.md )
-
-src_configure() {
- local myconfargs=(
- -c "$(tc-getBUILD_CC)" \
- -x "$(tc-getBUILD_CXX)" \
- -C "$(tc-getCC)" \
- -X "$(tc-getCXX)" \
- --prefix="${EPREFIX}"/usr \
- --sysconfdir="${EPREFIX}"/etc \
- --runstatedir="${EPREFIX}"/run \
- --localstatedir="${EPREFIX}"/var \
- $(usex network "" "--without-network") \
- $(use_with suid)
- )
- ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
-}
-
-src_compile() {
- emake -C builddir
-}
-
-src_install() {
- emake DESTDIR="${D}" -C builddir install
- keepdir /var/${PN}/mnt/session
-
- if use systemd; then
- sed -i -e '/systemd cgroups/ s/no/yes/' "${ED}"/etc/${PN}/${PN}.conf || die "Failed to enable systemd use in configuration"
- else
- sed -i -e '/systemd cgroups/ s/yes/no/' "${ED}"/etc/${PN}/${PN}.conf || die "Failed to disable systemd use in configuration"
- fi
-
- einstalldocs
- if use examples; then
- dodoc -r examples
- fi
-}
-
-pkg_postinst() {
- if ! use suid; then
- local oldver
- for oldver in ${REPLACING_VERSIONS}; do
- if ver_test "${oldver}" -lt 1.1.0; then
- ewarn "Since version 1.1.0 ${PN} no longer installs setuid-root components by default, relying on unprivileged user namespaces instead. For details, see https://apptainer.org/docs/admin/main/user_namespace.html"
- ewarn "Make sure user namespaces (possibly except network ones for improved security) are enabled on your system, or re-enable installation of setuid root components by passing USE=suid to ${CATEGORY}/${PN}"
- break
- fi
- done
- fi
-}