summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-11-24 00:41:00 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-11-24 00:44:50 +0100
commit3e0c11d084070dd2bb7999ec4f69596126728cbe (patch)
tree78be00ff909285a4a180130652bdae2771011441 /app-crypt/acme-sh
parentdev-python/bracex: Keyword 2.3_p1 arm, #882593 (diff)
downloadgentoo-3e0c11d084070dd2bb7999ec4f69596126728cbe.tar.gz
gentoo-3e0c11d084070dd2bb7999ec4f69596126728cbe.tar.bz2
gentoo-3e0c11d084070dd2bb7999ec4f69596126728cbe.zip
app-crypt/acme-sh: add 3.0.5
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-crypt/acme-sh')
-rw-r--r--app-crypt/acme-sh/Manifest1
-rw-r--r--app-crypt/acme-sh/acme-sh-3.0.5.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-crypt/acme-sh/Manifest b/app-crypt/acme-sh/Manifest
index f7bc015bfae9..da9ff4790509 100644
--- a/app-crypt/acme-sh/Manifest
+++ b/app-crypt/acme-sh/Manifest
@@ -1 +1,2 @@
DIST acme.sh-3.0.4.tar.gz 253157 BLAKE2B b1bde1ca31ef34c264f5045dd36220b3fd04230c59f7e65a9623681377dbde161ed3b92d86bd3e6f5a115d8847b1c2019bf984194f2901b52eb65abefad8bf81 SHA512 919987ac026366d245fa2730edf1212deafb051129811f35b482a30af9b0034a802baa218a35048e030795127cfeae03b4c3d4f12e580cd82edbacdd72e588e7
+DIST acme.sh-3.0.5.tar.gz 270092 BLAKE2B daba86ec09df80d374d1ea632f2bc84ecfbf665874d10fcb410e1bde7787551bb8b128e1ed0a4dc7943f821aaba6f9ae43b83225875f389d02d20d47b6fdf8f3 SHA512 882768c84182a8b11f4f315a9b429cd84399145a97b64772a42e0c7fc478c6c5f93a6c73289410b4d2108786a7c275e99f2e47991bdca315fd7d80a4282eefc9
diff --git a/app-crypt/acme-sh/acme-sh-3.0.5.ebuild b/app-crypt/acme-sh/acme-sh-3.0.5.ebuild
new file mode 100644
index 000000000000..c83e0e967104
--- /dev/null
+++ b/app-crypt/acme-sh/acme-sh-3.0.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+inherit optfeature
+
+DESCRIPTION="A pure Unix shell script implementing ACME client protocol"
+HOMEPAGE="https://github.com/acmesh-official/acme.sh"
+SRC_URI="https://github.com/acmesh-official/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+IUSE="selinux"
+
+RDEPEND="
+ dev-libs/openssl:0
+ net-misc/curl
+ net-misc/socat
+ selinux? ( sec-policy/selinux-certbot )
+"
+
+src_install() {
+ newdoc deploy/README.md README-deploy.md
+ newdoc dnsapi/README.md README-dnsapi.md
+ rm {deploy,dnsapi}/README.md || die
+ einstalldocs
+
+ exeinto /usr/share/acme.sh
+ doexe acme.sh
+
+ insinto /usr/share/acme.sh
+ doins -r deploy dnsapi notify
+
+ keepdir /etc/acme-sh
+ doenvd "${FILESDIR}"/99acme-sh
+
+ insinto /etc/bash/bashrc.d
+ doins "${FILESDIR}"/acme.sh
+
+ dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
+}
+
+pkg_postinst() {
+ optfeature_header "For webserver mode, install a supported web server:"
+ optfeature "using apache2 webserver mode" www-servers/apache
+ optfeature "using nginx webserver mode" www-servers/nginx
+}